Help with Reverse Camera!

Ask for help with doing something on your car here.

Help with Reverse Camera!

Postby Digital » Sun Sep 20, 2009 8:21 pm

Hi all,

I know there is a couple of threads floating around re: reverse cameras, but i thought i'd start a fresh one cos i have a specific issue.

My mate just hooked up my sub + amp and while we were at it, i hooked up a nice little CCD reverse camera.

Now we hooked up the power to the reverse light power so that it will power up when i select the reverse gear however we have a problem with this since you manually have to press 'aux' on either the head unit (has to be in radio or audio mode first) or using the touch screen menu on the display. It doesn't automatically come up. The problem seems to lie with the head unit itself and i'm wondering if anyone has had this issue or is able to shed some light?

i may not have explained it properly, but my mate Doug who did the install said he'll jump on here and try to explain a bit better...
MY08 2.5i - Satin Pearl White - Sat Nav [TEAM WHITE]
User avatar
Digital
-stickered-
 
Posts: 1082
Joined: Thu Mar 27, 2008 8:14 pm
Location: Melbourne, VIC
Car: MY08 2.5i Sedan - TEAM WHITE
Real name: Bobby
Profile URL: viewtopic.php?f=10&t=5767&start=0

Re: Help with Reverse Camera!

Postby CheesyMong » Sun Sep 20, 2009 10:52 pm

Any PICs of how you mounted it?

Cheers

Joel
CheesyMong
 
Posts: 386
Joined: Thu Jul 05, 2007 12:58 pm
Location: Perth
Car: MY07 Liberty GT-B 6MT

Re: Help with Reverse Camera!

Postby at last! » Sun Sep 20, 2009 10:59 pm

Sounds like he just plugged the camera into the RCA jack. To be activated when the gear selector is in reverse, it needs to be connected to the molex connector as shown in this picture.

Looking at the back of the screen

-top right pin (1) is video + or the center pin of your rca jack
-bottom left pin (4) is video shield this is also the detection input
Image

See this thread for full. info...http://www.legacygt.com/forums/showthread.php?t=36342

Hope that helps.
MY07 3.0R Auto
Reversing camera, "road kill" sound deadener in all doors and parcel shelf. Whiteline sway bars (front and rear).
Dyno Tune by Vin @ Docklands STi +10-12KW and much better response. Got a 3.0R? Do it now.
at last!
 
Posts: 58
Joined: Sun Mar 29, 2009 10:30 pm

Re: Help with Reverse Camera!

Postby Moi » Sun Sep 20, 2009 11:03 pm

at last! wrote:Sounds like he just plugged the camera into the RCA jack.


That's for the Kenwood 1200 Satnavs. I think you'll find Digital has the other model Satnav that comes with Bluetooth and radio integration etc... which might not have a dedicated reverse camera input.
Current: Subaru Legacy GT-spec.B MY07
Previous: Subaru Impreza WRX MY01

Image
User avatar
Moi
 
Posts: 134
Joined: Sat Aug 18, 2007 5:16 pm
Location: florey.act.au
Car: Subaru Legacy GT-spec.B MY07
Real name: Teck

Re: Help with Reverse Camera!

Postby Digital » Mon Sep 21, 2009 9:05 am

CheesyMong wrote:Any PICs of how you mounted it?

Cheers

Joel


i haven't mounted it yet, as i want to mount it kinda half-way up the handle above the licence plate if u get what i mean... cos if i mount it flush it looks kinda big...

will post up pics when i get it done
MY08 2.5i - Satin Pearl White - Sat Nav [TEAM WHITE]
User avatar
Digital
-stickered-
 
Posts: 1082
Joined: Thu Mar 27, 2008 8:14 pm
Location: Melbourne, VIC
Car: MY08 2.5i Sedan - TEAM WHITE
Real name: Bobby
Profile URL: viewtopic.php?f=10&t=5767&start=0

Re: Help with Reverse Camera!

Postby Digital » Mon Sep 21, 2009 9:07 am

Moi wrote:
at last! wrote:Sounds like he just plugged the camera into the RCA jack.


That's for the Kenwood 1200 Satnavs. I think you'll find Digital has the other model Satnav that comes with Bluetooth and radio integration etc... which might not have a dedicated reverse camera input.


correct, mine is the bluetooth model..

i pulled out the display, there's no RCA jacks on the back whatsoever, all info is going to the head unit...
MY08 2.5i - Satin Pearl White - Sat Nav [TEAM WHITE]
User avatar
Digital
-stickered-
 
Posts: 1082
Joined: Thu Mar 27, 2008 8:14 pm
Location: Melbourne, VIC
Car: MY08 2.5i Sedan - TEAM WHITE
Real name: Bobby
Profile URL: viewtopic.php?f=10&t=5767&start=0

Re: Help with Reverse Camera!

Postby at last! » Mon Sep 21, 2009 8:18 pm

Ahhh, sorry about that...perhaps post some pics. on the install along the way?
MY07 3.0R Auto
Reversing camera, "road kill" sound deadener in all doors and parcel shelf. Whiteline sway bars (front and rear).
Dyno Tune by Vin @ Docklands STi +10-12KW and much better response. Got a 3.0R? Do it now.
at last!
 
Posts: 58
Joined: Sun Mar 29, 2009 10:30 pm

Re: Help with Reverse Camera!

Postby Digital » Mon Sep 21, 2009 9:39 pm

i've posted some pics of install here: viewtopic.php?f=10&t=5767&start=15

but damn, i didn't take any shots of the back of the touchscreen.. so i dunno how helpful it is...

these are shots of my unit:
Image
Image
Image

this is the cord converter we used to get rca out for sub woofer and video input:
Image

detailed diagram of connector:
Image

hopefully i'll be able to get a better explanation from my mate who did the install........ i dont know all the technical jargon to properly explain what we did lol
MY08 2.5i - Satin Pearl White - Sat Nav [TEAM WHITE]
User avatar
Digital
-stickered-
 
Posts: 1082
Joined: Thu Mar 27, 2008 8:14 pm
Location: Melbourne, VIC
Car: MY08 2.5i Sedan - TEAM WHITE
Real name: Bobby
Profile URL: viewtopic.php?f=10&t=5767&start=0

Re: Help with Reverse Camera!

Postby fg1972 » Tue Sep 22, 2009 7:40 am

Just from looking at the pics, you need to short the red/white & blue/white wires to enable the AUX. If you wire a double pole relay to the reverse light circuit. When the reverse lights are on, the relay will be energized, one set of contacts would power the camera, the other set of contacts could short the two wires to enable AUX
User avatar
fg1972
 
Posts: 27
Joined: Sun Aug 16, 2009 5:11 pm
Car: MY07 3RB

Re: Help with Reverse Camera!

Postby Digital » Tue Sep 22, 2009 9:15 am

hey mate,

yes we shorted the red/white & blue/white wires already, so AUX is working, the issue is i have to manually press or select AUX and then chuck it into reverse for the image to come up...

i wonder if you're other method will make the image automatically pop-up...
also currently, after i switch out of reverse, it just leaves the screen blank, in AUX mode, it doesn't auto switch back to my previous environment, ie radio/dvd/mp3

i wonder if this a limitation of the head unit?
MY08 2.5i - Satin Pearl White - Sat Nav [TEAM WHITE]
User avatar
Digital
-stickered-
 
Posts: 1082
Joined: Thu Mar 27, 2008 8:14 pm
Location: Melbourne, VIC
Car: MY08 2.5i Sedan - TEAM WHITE
Real name: Bobby
Profile URL: viewtopic.php?f=10&t=5767&start=0

Re: Help with Reverse Camera!

Postby Ric » Tue Sep 22, 2009 10:27 am

Digital wrote:yes we shorted the red/white & blue/white wires already, so AUX is working, the issue is i have to manually press or select AUX and then chuck it into reverse for the image to come up...

Did you have them already shorted when you turned the unit on?
What happens if it is on already, and THEN you short them?
MY06 3.0RB 6MT Liberty Wagon. ---—▲≡≡≡

MGA-01 finally back on the track. 21-Jun-2015 at Sandown. Link
User avatar
Ric
Site Admin
 
Posts: 6260
Joined: Fri Oct 06, 2006 11:08 pm
Location: Melbourne
Car: MY06 3RB 6MT Wagon Pearl White
Real name: Ric
Profile URL: viewtopic.php?f=7&t=12

Re: Help with Reverse Camera!

Postby sphell » Tue Sep 22, 2009 10:22 pm

Hey guys, I'm the guy that installed Bob's sub/amp/camera. Ok, now the problem is this: The factory headunit and screen don't seem to have an input for the video signal from the reverse camera. It's strange because the headunit has a factory reverse wire 12V+ input (brown/yellow) going into it, however putting the car into reverse does nothing on the screen. There is no Reverse Video signal input on the Cord Convert plug either. So at the moment I've just run the reverse camera into the auxillary video input which means Bob has to push AUX and have the car in reverse if he want's to use the camera.

By the way guys it's nothing to do with shorting the AUX pins on the cord convert. If you have them separated, the AUX icon is greyed out, and if you short them together then it lights up and you can select AUX. If you have the unit on and short them, then it does the same thing, the greyed out icon turns to colour and you can select it.

I just find it strange that the unit has a factory run reverse wire going into it but it does nothing. There is another plug on the back of the unit that is not being used, is it possible there is another plug you have to buy from Subaru that has a proper reverse camera video input?
sphell
 
Posts: 2
Joined: Tue Sep 22, 2009 9:54 pm

Re: Help with Reverse Camera!

Postby smythie » Tue Sep 22, 2009 10:32 pm

Interesting. For the guys who have rear parking sensors, does the info show up on the satnav screen or is it just an audible alarm?
Flag Bitch

MY06 3.0RB
User avatar
smythie
 
Posts: 5227
Joined: Mon Oct 27, 2008 12:46 pm
Location: Sydney (w-end)
Car: MY06 3RB - Blue

Re: Help with Reverse Camera!

Postby CheesyMong » Tue Sep 22, 2009 10:35 pm

Hey Digital did you post the question on LegactGT as well as there are quite a few people using the factory Screen with reverse cameras, so information may be a bit more forthcoming over there?

Cheers

Joel
CheesyMong
 
Posts: 386
Joined: Thu Jul 05, 2007 12:58 pm
Location: Perth
Car: MY07 Liberty GT-B 6MT

Re: Help with Reverse Camera!

Postby Ric » Tue Sep 22, 2009 10:57 pm

Have a look at this post someone called muzza (from Melbourne!) put on a Forester board a few months ago:

http://www.subaruforester.org/vbulletin ... avi-51351/

He's saying the factory reverse camera goes via a seperate 8 pin connector!

Is this the same unit?
Image

I found it via this topic: http://forums.nasioc.com/forums/showpos ... stcount=11
MY06 3.0RB 6MT Liberty Wagon. ---—▲≡≡≡

MGA-01 finally back on the track. 21-Jun-2015 at Sandown. Link
User avatar
Ric
Site Admin
 
Posts: 6260
Joined: Fri Oct 06, 2006 11:08 pm
Location: Melbourne
Car: MY06 3RB 6MT Wagon Pearl White
Real name: Ric
Profile URL: viewtopic.php?f=7&t=12

Next

Return to How do I?

Who is online

Users browsing this forum: No registered users and 2 guests