Dim HID Xenons - 2011 Liberty 2.5 CVT

Ask for help with doing something on your car here.

Dim HID Xenons - 2011 Liberty 2.5 CVT

Postby SlowClown » Wed Nov 17, 2021 9:52 am

Hi guys,

I've been trying to solve this problem for a while now. Not so long ago I purchased a 2011 Liberty wagon with 300kkms on the clock. Goes alright, but some things wearing out of course. One of those things is the lights - they're HIDs, but basically useless when it comes to illuminating the road.

I'd love some advice. I don't care how I get to it, but I want to get functional headlights on the car for as little cash as possible.

Things I've tried so far:
- Polishing the lenses. This helped some, but the lenses seem to have some level of degradation on the inside which I can't get to.
- Changing the bulb - no change. Used a Phillips, so presumably high quality, but light output was pretty much exactly the same.
- Changing the ballast. Went half-arsed here, because I wasn't sure this was the problem, and bought a cheapo. Actually made the problem worse in that the light I switched would flicker (not rapidly, it would turn on for a bit, then off, then on, then-on-then-off, and so on)

Things I haven't tried:
- Changing the projector - I read that this is likely to be degraded after so much time. I don't know how to check this or how I'd obtain a replacement if it was the case.

I'm open to anything though. I almost pulled the trigger on a couple of cheap Halogen assemblies (such as these, but didn't in the end because a) I've heard they could be really rubbish b) I'm not sure if they would connect up being for Halogen bulbs) So yes, I'm happy to completely swap out of the headlights if the price is right, or swap out just the low beam component if that is possible. Anything that gets me functional lights without spending $1000+ per new assembly for an OEM replacement.

If anyone can confirm or correct the following, I would appreciate it. From what I understand, the fact that the HID bulbs are consistently turning on means that I don't have a problem with either the igniter or the voltage being supplied from the battery. I also gather that while the light profile of an HID light will change overtime mainly in terms of colour and somewhat in terms of brightness, they are an ON or OFF and not anything in between kind of system - i.e. an HID would never turn on but be 50% as bright as it was before because it was only receiving 50% of the power. If this is the case, can I be reasonably certain that my problem does not lie with the electrics and the light being produced, but must be either the projector/reflector or the lens?

Happy to hear all ideas.
SlowClown
 
Posts: 1
Joined: Fri Feb 12, 2021 11:06 am

Re: Dim HID Xenons - 2011 Liberty 2.5 CVT

Postby bigBADbenny » Thu Nov 25, 2021 6:27 pm

How’s the igniter/socket looking?

My oem hid igniters crapped out at around 200kkm, replaced with stock salvage ballasts & igniters.

I’m not sure of the process for putting new sockets on but looks to be crimped connections?
User avatar
bigBADbenny
 
Posts: 10055
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop


Return to How do I?

Who is online

Users browsing this forum: No registered users and 4 guests