ECU hangs then knocks

Tuning, diagnostics, ECUs and associated bits and bytes
Forum rules
Please respect copyright.
Do not post full copies of professionally tuned roms!

ECU hangs then knocks

Postby cynner » Tue Mar 24, 2015 10:26 pm

This issue has been haunting me for a while...

For a number of months my ECU data scan would drop into negative learned ignition timing off throttle... initially around -1.5. Then a while later it was showing -3 off throttle, then very occasionally -3 under light throttle.

Since replacing my fuel pump and turbo with a TD05-18g (maybe coincidence), I found a few times it dropped into -6 and later -11 degrees of timing at light throttle (at this point the car was not driveable). I had to reset the ECU and things would be OK for a while (not ideal I know).

I then replaced the ECU data scan and got a BtSsm - gives me a little bit more data to log.

I was noticing FKC at around -3psi, light accelleration, 0.97 load, 2000rpm. I could bring on the knock by changing gears a little early into 3rd and increasing the throttle to try and get it up to atmosphere/0psi.

So I started troubleshooting the knock:
- mechanic confirmed it's actual knock/pinging with knock ears on the block
- Matt (tuner) tried pulling heaps of timing out, made no difference
- vacuum leaks checked (turbo inlet pipe a little loose - fixed)
- found a cracked breather hose - replaced
- inspected PCV valve - functions ok
- boost leak tested system - all good
- pressure tested exhaust system (turbo up-pipe gasket leaking - fixed)
- cleaned MAF sensor
- checked and cleaned o2 sensors
- had rear o2 sensor disabled in test tune - made no difference
- had wastegate set to 0 in tune to rule out wastegate chatter
- had fuel pressure tested (DW65C fuel pump relatively new - all ok)
- had turbo fitment checked (Blouch TD05 18g fitted recently - all ok)
- had heaps of timing pulled from the tune - made no difference

After all this was done, not a bit of difference :(

However, Matt (tuner) noticed that pretty much every time the knock occurred – the "time (ms)" in the log file hung for sometimes up to 1.8 seconds. Matt suspects the ECU is hanging, maybe due to something shorting out, who knows. And this hang would cause timing and fuelling to lag, which would cause the knock.

Here's a log with knock in a few places - http://www.datazap.me/u/cynner/ecu-drop ... 5-21-23-24 (you'll need to view time(ms) separately as the values are so high it flattens the graph).

Has anyone seen this kind of thing before? Would the ECU be hanging because it is processing the knock and working to correct? Or would it be hanging because of an electrical issue, which is then causing the knock? (which comes first?)

My next step is to check the spark plugs...

Just posting here hoping someone might have some bright ideas? :?

Kim
User avatar
cynner
 
Posts: 460
Joined: Fri Jul 05, 2013 4:38 pm
Location: Hobart, Tasmania
Car: MY08 GT Wagon
Real name: Kim
Profile URL: viewtopic.php?f=10&t=23586

Re: ECU hangs then knocks

Postby bigBADbenny » Wed Mar 25, 2015 9:11 am

I know you've ruled it out, but my Pierburg on the custom bracket rattled like mad!

I made a 360 x 360 soft rubber isolation mount for it and loosely ziptied it to the custom mount, making sure none of the plugs or leads were touching either.

I'm extremely careful to have absolutely everything in the engine bay rattle and resonance free.
Especially any covers.
Its a tinfoil hat thing for sure but it works for me.

As per my PM I'll post over my Listen-Up remote mic so you can listen to the noises yourself.
User avatar
bigBADbenny
 
Posts: 8105
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: ECU hangs then knocks

Postby KiDo_Tuning » Wed Mar 25, 2015 2:07 pm

Here we go. Notice how it randomly drops out, then when spark resumes, its instantly starting to pull timing

15.4 AFR's on resume is 1.3 AFR leaner than it was before it dropped out
Attachments
Kim_ECU_Dropout_2.png
Kim_ECU_Dropout_2.png (170.64 KiB) Viewed 1947 times
KiDo Racing Tunes Info: HERE

Great minds discuss ideas;
Average minds discuss events;
Small minds discuss people
User avatar
KiDo_Tuning
 
Posts: 2798
Joined: Sun Jun 10, 2012 11:53 pm
Car: Subarus + Nissans
Real name: Matt

Re: ECU hangs then knocks

Postby dr20t » Wed Mar 25, 2015 2:34 pm

Matt remember my ecu was having the same problems with the feedback dropout?

Any chance this has to do with calculated engine torque patch?
Addicted to corn juice....

My FrankenStien build thread here: viewtopic.php?t=14137
User avatar
dr20t
 
Posts: 4180
Joined: Sun Oct 23, 2011 10:43 pm
Location: South West Sydney NSW
Car: 04 Liberty GT Auto
Real name: Mick
Profile URL: viewtopic.php?t=14137

Re: ECU hangs then knocks

Postby KiDo_Tuning » Wed Mar 25, 2015 2:46 pm

dr20t wrote:Matt remember my ecu was having the same problems with the feedback dropout?

Any chance this has to do with calculated engine torque patch?


Its stock values. I ahve also seen it in 3 stock cars(never been tuned and they still are untuned, they were that bad) and Kekotic also had it. I dont remember what he did to fix it but from memory, he had an OBD2 port issue
KiDo Racing Tunes Info: HERE

Great minds discuss ideas;
Average minds discuss events;
Small minds discuss people
User avatar
KiDo_Tuning
 
Posts: 2798
Joined: Sun Jun 10, 2012 11:53 pm
Car: Subarus + Nissans
Real name: Matt

Re: ECU hangs then knocks

Postby Robbks » Wed Mar 25, 2015 2:49 pm

Can you patch the ECU to flash a dash light when it knocks?
so that you can monitor it without anything in the OBD port?
coyote wrote:Sure, a GTR is fast ... but it's about as interesting as listening to grass grow.
User avatar
Robbks
 
Posts: 2185
Joined: Wed Jan 05, 2011 8:21 am
Location: Hobart, Tas
Car: MY06 3.0RB Wagon
Real name: Rob
Profile URL: viewtopic.php?f=10&t=12350

Re: ECU hangs then knocks

Postby cynner » Wed Mar 25, 2015 2:51 pm

Did you end up working out what was causing this in yours dr20t?
User avatar
cynner
 
Posts: 460
Joined: Fri Jul 05, 2013 4:38 pm
Location: Hobart, Tasmania
Car: MY08 GT Wagon
Real name: Kim
Profile URL: viewtopic.php?f=10&t=23586

Re: ECU hangs then knocks

Postby THE SpecB » Wed Mar 25, 2015 4:01 pm

Robbks wrote:Can you patch the ECU to flash a dash light when it knocks?
so that you can monitor it without anything in the OBD port?


Matt can do this I'm sure ..
Newport Blueeeee
THE SpecB
 
Posts: 369
Joined: Fri Nov 14, 2014 5:03 pm
Car: Newport Blue SpecB GT

Re: ECU hangs then knocks

Postby bigBADbenny » Wed Mar 25, 2015 4:28 pm

OT but btSsm has an auto knock logging feature.
The intent for the feature has been refined.
I'll post some examples soon :)
User avatar
bigBADbenny
 
Posts: 8105
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: ECU hangs then knocks

Postby cynner » Mon Mar 30, 2015 3:56 pm

Just an update...

I'm suspecting that the ECU is not actually dropping out... it is simply lagging a little when the extra knock "data" is sent to the ODB - probably because I'm logging too many fields. I've tried lowering the monitoring to just boost and KCA and the ECU/logging drops out far less.

I've also replaced the knock sensor and spark plugs, which made no difference. As well as testing another MAF sensor and o2 sensor, which also made no difference.

Not sure where to go from here... :(
User avatar
cynner
 
Posts: 460
Joined: Fri Jul 05, 2013 4:38 pm
Location: Hobart, Tasmania
Car: MY08 GT Wagon
Real name: Kim
Profile URL: viewtopic.php?f=10&t=23586

Re: ECU hangs then knocks

Postby norbs » Mon Mar 30, 2015 10:40 pm

Could be a comms. issue. Have you tried a laptop with cable? Also have you tried a stock or last known working tune? Or is this happening even on the stock tune? I once had a strange issue where I wasn't getting any values in learning view and car was just running odd. Somehow my ROM was corrupted. So I used original stock map and copied/pasted all the modified tables from the latest tune into the original and flashed it. Voila, car ran perfect and LV was back. I'm sure Matt can check this though.
'05 Lib GT with a few mods :-)
norbs
 
Posts: 360
Joined: Mon Oct 09, 2006 2:11 pm
Location: Melbourne

Re: ECU hangs then knocks

Postby cynner » Tue Mar 31, 2015 9:00 pm

Loaded a stock tune (Matt tweaked it slightly to accommodate for the 3-port and bigger TMIC). IAM dropped to 0.5 very quickly, and I was still able to get it to knock at roughly the same spots (a bit harder to knock due to the IAM). So I think that confirms it's not a tune issue...
User avatar
cynner
 
Posts: 460
Joined: Fri Jul 05, 2013 4:38 pm
Location: Hobart, Tasmania
Car: MY08 GT Wagon
Real name: Kim
Profile URL: viewtopic.php?f=10&t=23586

Re: ECU hangs then knocks

Postby dr20t » Tue Mar 31, 2015 10:33 pm

Check your ocv and avcs cam gears for noise?

Perhaps worth smoke testing it for air leak somewhere in the inlet tract (maybe a crack in inlet manifold or one of the pipes etc that may be causing it to run lean then knock)

Throttle body? Throttle tip in? Fuel regulator? Fuel dampener?

Dirty fuel filter or fuel leak at the cradle (missing o-ring)??

Throwing ideas your way to try to assist

Mick
Addicted to corn juice....

My FrankenStien build thread here: viewtopic.php?t=14137
User avatar
dr20t
 
Posts: 4180
Joined: Sun Oct 23, 2011 10:43 pm
Location: South West Sydney NSW
Car: 04 Liberty GT Auto
Real name: Mick
Profile URL: viewtopic.php?t=14137

Re: ECU hangs then knocks

Postby cynner » Tue Mar 31, 2015 11:22 pm

Thanks for the ideas. Hmm, had fuel pressure tested - that would rule out regulator/o-ring leak...?

Had the car tested for boost leaks (not smoke test though, pressure test) - that would find crack in the inlet manifold?

Might get the fuel pump/filter inspected, just in case the filter sock has fallen off or something...
User avatar
cynner
 
Posts: 460
Joined: Fri Jul 05, 2013 4:38 pm
Location: Hobart, Tasmania
Car: MY08 GT Wagon
Real name: Kim
Profile URL: viewtopic.php?f=10&t=23586

Re: ECU hangs then knocks

Postby dr20t » Wed Apr 01, 2015 6:16 am

Worth a look to see if its impeding flow

And yes smoke test will reveal any intake tract leaks

Do you have a wideband gauge and can log what's happening with afr's properly when you roll on the throttle

Check other things too like loose heat shield (unlikely due to the knock being replicatable and constant but worth a look)

Check fuel injectors. Good way to check is use the jack handle in your boot (underside of the boot tray). Put the flat end on the injector and the round end to your ear. Check each injector seperately. You should hear slight wooshing and faint ticking being the injector pulsating. If you hear one or more being noisier than another then could be a dead injector causing lean out and knock. Injector cleaner may work to unstick it if its just stuck but otherwise may need to be replaced

Good luck

Mick
Addicted to corn juice....

My FrankenStien build thread here: viewtopic.php?t=14137
User avatar
dr20t
 
Posts: 4180
Joined: Sun Oct 23, 2011 10:43 pm
Location: South West Sydney NSW
Car: 04 Liberty GT Auto
Real name: Mick
Profile URL: viewtopic.php?t=14137

Next

Return to Tuning

Who is online

Users browsing this forum: No registered users and 2 guests