aftermarket HU with Mcintosh amp.

Stereos, amps, phone kits, Navi...

aftermarket HU with Mcintosh amp.

Postby dogsfoot » Thu Sep 28, 2017 10:42 am

Ok, so just bought a Kenwood DDX-4016BT HU to install in 06 Liberty with the Mcintosh sytem.
I picked up a fascia from amazon for $30 and cut it down to suit.
Aerial adapter.
Found a 20 pin Din cable.

Is it as simple as cutting the 20 pin cable and adding RCA leads to it. The HU has front, rear and subwoofer rca output.
I have the wiring/pin pdf for the Din cable so should be easy, right ????? :lol: :lol: :lol:

Anyone have experience doing this and is it straight forward.
User avatar
dogsfoot
 
Posts: 33
Joined: Mon Feb 01, 2010 2:00 pm
Location: melbourne
Car: my06 3.0r-b wagon

Re: aftermarket HU with Mcintosh amp.

Postby steveP » Fri Sep 29, 2017 9:53 am

I did this, in reverse. Kept the stock head unit for the stock look and replaced the crappy factory amp.

2 things:
1 - Yes, you can splice into the 20-din cable. However the individual wires are very small and fiddly, so take your time. I used the wiring diagram on this forum and it all worked.
2 - I wouldn't bother keeping the factory amp. You've already done the tricky bit, of finding a fascia and getting it to fit. Now you just need to plug the RCAs into a new amp and you're done. Plus you get more power and better level controls.
steveP
 
Posts: 11
Joined: Mon Feb 27, 2017 9:12 am
Car: MY08 Liberty B Spec
Real name: Steve

Re: aftermarket HU with Mcintosh amp.

Postby bigBADbenny » Fri Sep 29, 2017 12:09 pm

User avatar
bigBADbenny
 
Posts: 8042
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: aftermarket HU with Mcintosh amp.

Postby Tresidder17 » Fri Sep 29, 2017 5:33 pm

From my research, yes you can splice rca leads into the 20 pin din cable - only use rca output, do not wire regular speaker output from your head unit to your amp this will likely damage electronics as it is designed to power the speakers, not just send an audio signal.

I just purchased a kenwood ddx7017bt and will be installing it in my 2006 MY07 3.0r spec.b this week and i will be keeping the stock mcintosh amp. assuming all things go well i will be attempting to take many photos and post a thorough guide on this forum as i dont feel there is a detailed enough guide and it could be beneficial to the community. so waiting for that may work in your favour. Im hoping to have the guide up next weekend assuming i find the spare time.

in the mean time, take a look at gfennessey's post (viewtopic.php?f=22&t=12400). his post has a lot of information and what i will be doing is largely based off his work.

however, gfennessey's post doesn't cover things like the self learning swc that kenwood (and other brand) units have. i will be installing these and it will be included in my guide
Tresidder17
 
Posts: 14
Joined: Mon Mar 20, 2017 4:11 pm
Location: Adelaide
Car: MY07 3.0 Spec.B 5EAT

Re: aftermarket HU with Mcintosh amp.

Postby Tresidder17 » Sat Oct 07, 2017 10:56 am

my install all went as planned and i'll make a post as soon as i can.
I apologise if you were waiting for my post to before doing your own install as i will not have time to post it this weekend as promised. I will have it posted next weekend
Tresidder17
 
Posts: 14
Joined: Mon Mar 20, 2017 4:11 pm
Location: Adelaide
Car: MY07 3.0 Spec.B 5EAT

Re: aftermarket HU with Mcintosh amp.

Postby dogsfoot » Wed Oct 11, 2017 1:40 pm

Tresidder17 wrote:my install all went as planned and i'll make a post as soon as i can.
I apologise if you were waiting for my post to before doing your own install as i will not have time to post it this weekend as promised. I will have it posted next weekend


Looking forward to you install post. :D
User avatar
dogsfoot
 
Posts: 33
Joined: Mon Feb 01, 2010 2:00 pm
Location: melbourne
Car: my06 3.0r-b wagon

Re: aftermarket HU with Mcintosh amp.

Postby Tresidder17 » Sat Oct 14, 2017 1:46 pm

Tresidder17
 
Posts: 14
Joined: Mon Mar 20, 2017 4:11 pm
Location: Adelaide
Car: MY07 3.0 Spec.B 5EAT


Return to Audio options

Who is online

Users browsing this forum: No registered users and 3 guests