Engine light on with flashing cruise control light

Posts specific to the 2.5 litre turbo engine

Re: Engine light on with flashing cruise control light

Postby NA84WA » Thu May 12, 2011 6:46 pm

Had the fault cleared on Tuesday. The fault was P4020 Catalyst System Efficiency Below Threshold (Bank 1). Just after start up today the CEL light came back again. The tuner adjusted the parameter and its been good until today.

Does anyone know what cell the catalytic converter is in the PHAT DP?

Rung Subaru today and they quoted me 410 for a new O2 sensor which is bloody steep!! Car is getting serviced tomorrow and going to run a diagnostic on it and drive the car and log some data to see what the sensor is doing. If all is good need to go back to the tuner in the afternoon to see what they can adjust but to me sounds like its kicking up the fault due to the higher flowing cat.

Maybe a new sensor is what it needs but trying to avoid that as its so expensive for troubleshooting purposes.
User avatar
NA84WA
 
Posts: 90
Joined: Wed Nov 03, 2010 5:22 pm
Location: Perth, WA
Car: Subaru Liberty MY08 GT Spec B
Real name: Nick
Profile URL: viewtopic.php?f=10&t=12211

Re: Engine light on with flashing cruise control light

Postby fatfrog02 » Sun Sep 25, 2011 7:43 am

Wonder if Ric should make this thread a sticky. Seems like a common problem with Post facelift Gen4 GTB.
User avatar
fatfrog02
 
Posts: 432
Joined: Fri May 16, 2008 8:17 am
Location: Blue Mts, Sydney NSW

Re: Engine light on with flashing cruise control light

Postby Sancheezy » Sun Oct 02, 2011 3:27 pm

Yep. Mine did it on the freeway today as well, I hope it's only a sensor and nothing bigger. I can handle replacing that for $500 or so. I have noticed a little backfiring in first and second too lately.

Has anyone had any further progress on the cause?
Sancheezy
 
Posts: 16
Joined: Wed Dec 01, 2010 4:19 pm
Location: Sydney Hills District
Car: '07 GT-B Wagon

Re: Engine light on with flashing cruise control light

Postby sundayDriver » Thu Oct 06, 2011 8:43 pm

I've had two in the last 12 months, the last one was when my tank was full of Shell vortex (supposedly 98). Don't know if this might have something to do with it.
It's the fastest who gets paid, it's the fastest who gets laid.
sundayDriver
 
Posts: 831
Joined: Wed Jan 09, 2008 2:16 pm
Location: A.C.T.

Re: Engine light on with flashing cruise control light

Postby Sancheezy » Sat Oct 08, 2011 9:52 pm

Had my mechanic check it out. Like someone else has mentioned, it was a cat problem. Now the pipe has been doing it's thing for a while, the flow has "loosened up" and the ECU was wigging out. Reset the ECU and a slight adjustment of tolerances and it's good to go again. :D Pumped it wasn't anything terminal!
Sancheezy
 
Posts: 16
Joined: Wed Dec 01, 2010 4:19 pm
Location: Sydney Hills District
Car: '07 GT-B Wagon

Re: Engine light on with flashing cruise control light

Postby CheesyMong » Sat Jan 05, 2013 6:51 pm

Sorry to dig up an old thread but I've been too lazy to get this issue sorted...I'm guessing tweaking the threshold on the ECU fixes this error anyone know off the top of their head which setting needs to be tweaked?

Getting ready to sell the car and want to get it sorted..

Cheers

Joel
CheesyMong
 
Posts: 386
Joined: Thu Jul 05, 2007 12:58 pm
Location: Perth
Car: MY07 Liberty GT-B 6MT

Re: Engine light on with flashing cruise control light

Postby Weerty » Wed Mar 27, 2013 4:44 pm

Seems i am now a member of the club.. came on after driving in cool weather/rain on Monday night. (normal driving only - ie: not spirited!)
pulled over, turned off then on, didn't clear kept driving.

same as others reported, engine light constant, flashing [S] and 'cruise' lights..

called Subaru service centre on Tuesday morning, they said they were all booked until after Easter, but would slot me in if i could drop it off on wed (today)

dropped it off this morning, got a call at lunch time saying the codes related to the cat-con.

but this is not where the story ends.. while driving the car to the service centre it develops a mechanical gargling type sound from the engine bay during idle, but worse under acceleration - so i get them to check it - "havent heard that sound before"... heart sinks becaus i know this is going to cost me..

they seem to think 2 possibilities; 1 something in the exhaust, 2 turbo releated... they are pulling the exhaust off at the cat this afternoon.. will keep you posted with the details.

(btw - my car has no performance mods)
User avatar
Weerty
 
Posts: 130
Joined: Fri May 28, 2010 4:00 pm
Location: Perth
Car: MY08 Liberty Wagon 2.5T GT Spec B
Real name: Dave

Re: Engine light on with flashing cruise control light

Postby Weerty » Wed Mar 27, 2013 6:21 pm

its the 'news' i didnt want to hear...

turbo has gone...

$4100 for brand new oem

$800 for 2nd hand oem (subject to availability)

$1600 to rebuild existing (which is sent to melb!)

OR

i can sort out another solution ie non standard/original part at my own cost..

FML...
User avatar
Weerty
 
Posts: 130
Joined: Fri May 28, 2010 4:00 pm
Location: Perth
Car: MY08 Liberty Wagon 2.5T GT Spec B
Real name: Dave

Re: Engine light on with flashing cruise control light

Postby bass_straitener » Wed Mar 27, 2013 6:49 pm

Weerty wrote:its the 'news' i didnt want to hear...

turbo has gone...

$4100 for brand new oem

$800 for 2nd hand oem (subject to availability)

$1600 to rebuild existing (which is sent to melb!)

OR

i can sort out another solution ie non standard/original part at my own cost..

FML...


There are quite a few people looking to sell their stock VF46 turbos. I'm sure they'll pipe in.

Another option is to get something like a VF52 turbos which is a direct bolt on and you'll see some performance gains too with a retune.
"If A is a success in life, then A equals x plus y plus z. Work is x; y is play; and z is keeping your mouth shut."
User avatar
bass_straitener
-stickered-
 
Posts: 2247
Joined: Mon Jul 25, 2011 8:31 pm
Location: Melbourne, Victoria
Car: MY12 C63
Real name: Bruce
Profile URL: viewtopic.php?f=10&t=14781

Re: Engine light on with flashing cruise control light

Postby Weerty » Wed Apr 03, 2013 11:52 am

thanks for the info bruce..

have had Owen contact me, (only saw his msg this morning) and waiting on his reply.


apparently there are no 2nd had oem turbos around (that the subaru 'service' dept could find - how convenient) and wanted to send to melb for a rebuild (looking between 1600-3100 + plus labour) - and would be without the car for another 2 weeks.

so hopefully all goes well here... i have made the service dept hold off sending mine until i hear back.
User avatar
Weerty
 
Posts: 130
Joined: Fri May 28, 2010 4:00 pm
Location: Perth
Car: MY08 Liberty Wagon 2.5T GT Spec B
Real name: Dave

Re: Engine light on with flashing cruise control light

Postby cmike5 » Sat Nov 23, 2013 1:36 pm

sundayDriver wrote:I've had two in the last 12 months, the last one was when my tank was full of Shell vortex (supposedly 98). Don't know if this might have something to do with it.


Funny you say that. I've owned my 2.0r Liberty for a couple of months. First time I filled it up with Vortex 98 the problem popped up (on came the engine light and cruise control); however, I did find that my flat spot (between 2.5K revs and 3K) disappeared.
cmike5
 
Posts: 1
Joined: Sat Nov 23, 2013 1:13 pm
Car: Subaru Liberty 2.0r MY07

Re: Engine light on with flashing cruise control light

Postby mbikeboy » Sat Aug 05, 2017 8:55 pm

We just had the very same thing happen to us tonight on our MY12 GT auto wagon. A few beeps, then the transmission flashed and disappeared, engine, traction control, park brake lights on, stuck in sports mode, and cruise control flashing. We had been driving for 40 mins with me trying an economy run on the freeway (managed best figures of 8.4lt/100klm btw!), pulled into Macca's for 20 mins, and almost immediately after leaving while driving like a grandpa, boom, there's a christmas tree of lights on the dash. :angry2:

I knew straight away it was a kind of false reading from an ECU to have so many conflicting warning lights displayed and just needed a "quick test and clear". I checked the owners manual just for peace of mind, and drove it home without any dramas. The car is stock standard with no modifications, was serviced last week before we bought it, and had no issues whatsoever. I'll try a few things suggested in this thread tomorrow and let you know how it goes. The worst case scenario is I take it to the dealership and they can sort it out for me under extended warranty. :lol:
mbikeboy
 
Posts: 4
Joined: Tue Aug 01, 2017 8:02 am
Car: MY12 Liberty GT Premium B5 Wagon

Re: Engine light on with flashing cruise control light

Postby fedaykin » Mon Aug 07, 2017 11:17 am

Buy a $30 bluetooth OBD2 module and use your phone to get the code. I bet it's O2 sensor :P
fedaykin
 
Posts: 595
Joined: Wed Apr 08, 2015 10:09 am
Location: Sydney
Car: MY10 GT Wagon 6MT

Re: Engine light on with flashing cruise control light

Postby mbikeboy » Mon Aug 07, 2017 12:34 pm

fedaykin wrote:Buy a $30 bluetooth OBD2 module and use your phone to get the code. I bet it's O2 sensor :P



Funnily enough I've got one of those coming in the post, hehe!

I took the car into the dealership first thing this morning to have the codes read and cleared...stung for $77 straight off the bat! :roll:

The fault-codes which came up were:
P1710 - Torque Converter Turbine Speed Signal
C0057 - ECM Control Module

I've driven around for a fair bit this morning running errands and so far so good. Not the ideal start to ownership though...eh well! :(
mbikeboy
 
Posts: 4
Joined: Tue Aug 01, 2017 8:02 am
Car: MY12 Liberty GT Premium B5 Wagon

Re: Engine light on with flashing cruise control light

Postby lhuynh » Sun Feb 18, 2018 8:13 am

This happened to me yesturday afternoon waiting at the lights 10 mins from home.

Event leading up to this;

1. Fill up on Shell 98
2. Cruised through national park in sport sharp manual mode staying between 3rd and 4th majority of the time
3. Lights just came up at the lights on the way home

This morning;

1. Car still starts
2. Goes through the gears just fine

Being a sunday and no access to code reader, is there anything that I can do? unplug battery? anything I can check?

Cheers.
lhuynh
 
Posts: 46
Joined: Mon Aug 12, 2013 10:00 pm
Location: Ryde NSW 2112

PreviousNext

Return to 2.5T engine specific

Who is online

Users browsing this forum: No registered users and 2 guests