Engine light on with flashing cruise control light

Posts specific to the 2.5 litre turbo engine

Re: Engine light on with flashing cruise control light

Postby Arith » Wed Jul 08, 2009 12:22 am

tehx wrote:One reason is that the ECU's parameter's for emission’s are exceeded after work to the exhaust system.

So did you have any exhaust work done on your car recently? I also know that quite a few people have gotten this after a tune as well, without having done additional exhaust modifications after the tune.

[ Former Liberty ... Slightly Modified -> Click
here for modifications & profile ]
User avatar
Arith
-stickered-
 
Posts: 6111
Joined: Mon Oct 08, 2007 2:05 am
Location: Sydney (Wes-Sieed!)
Car: MY11 Volvo S60 T6
Real name: Jim

Re: Engine light on with flashing cruise control light

Postby tehx » Thu Jul 09, 2009 12:45 pm

Yup, new DP, CAT and stainless exhaust. This was done prior to the tune.
MY07 Subaru Liberty GT Spec.B - Tuned by Pulse
| Hyperflow TMI | Custom Stainless Exhaust from Turbo back - developed & tested by Pulse Racing |Custom Chrome CAI | Organic Clutch | DBA 4000 Slotted Rotors & Redstuff pads | Whiteline Swaybars | STI Rear Lip & Front Spoiler | STI Short Shifter & Gear Knob | LED Internal, Park, Plate & Fog lamps - 6000k HIDs | OpenECU | Custom CarPC by M@ |
tehx
 
Posts: 75
Joined: Tue Feb 10, 2009 10:21 pm
Location: Canberra, Australia (ACT)
Car: Liberty GT Spec.B - Tuned by Pulse
Real name: M@

Re: Engine light on with flashing cruise control light

Postby anfs » Tue Nov 23, 2010 9:48 pm

Hey all,

Same thing happened to me recently CEL went on and cruise control blinking like an annoying glow stick!!
Did some research, will try the battery option first, seems to be the easiest and quickest idea in hopes that it does something.
User avatar
anfs
 
Posts: 15
Joined: Tue Mar 17, 2009 12:06 pm
Location: Sydney

Re: Engine light on with flashing cruise control light

Postby Kekotic » Tue Nov 23, 2010 10:03 pm

Anfs do you have any intake mods?
User avatar
Kekotic
-stickered-
 
Posts: 6436
Joined: Tue Jun 08, 2010 6:46 pm
Car: MY07 Liberty GT Spec.B
Real name: Kieran
Profile URL: viewtopic.php?f=10&t=13066

Re: Engine light on with flashing cruise control light

Postby silver spec » Mon Dec 06, 2010 8:45 am

same has happened to me, but it was not an exhaust problem. I had disconnected the, what i believe to be the air flow sensor/ outside air temp sensor thats on the intake box. I disconnected to fiddle round, then noticed the same simptoms. The problem went away after a few drives as the ecu had to re learrn, i suppose.I have now recently fitted a pod filter for noise testing as i want to make my own cai system, it was fine until the other night, while doing a right hander i noticed i has come back on. Do not know what it is this time, i suspect the sensor maby too close to turbo and is getting to hot, or positioning is not ideal. Dunno, hopefully will sort itself out again.
User avatar
silver spec
 
Posts: 7
Joined: Sat Sep 25, 2010 9:55 am
Location: Macleod ViC
Car: MY07 spec-b wagon 6spd turbo
Real name: Daniel

Re: Engine light on with flashing cruise control light

Postby fatfrog02 » Tue Apr 12, 2011 10:57 pm

My CEL came on again the other day. Same thing. CEL on, cruise light and s flashing. Unable to use cruise or change into sport sharp mode. Pissing me off a bit actually. Anyone got any more ideas??
User avatar
fatfrog02
 
Posts: 432
Joined: Fri May 16, 2008 8:17 am
Location: Blue Mts, Sydney NSW

Re: Engine light on with flashing cruise control light

Postby fatfrog02 » Tue Apr 12, 2011 11:01 pm

Arith wrote:What makes this case unique is you're pretty much the only one who's gotten the dump pipe who has a pre-existing tune already. The tune may be optimised for a stock setup, and probably doesn't like the new addition. But it looks like your choices are limited, Adam. :?

1) Go back to the stock dump pipe
2) Get a re-tune
3) Replace the O2 sensors

All the choices seem to involve a bit of money. I would opt for choice 2 if I were you. You're only paying for a re-tune, and even the crappiest tuner re-tuning in the safest possible way would be better than your existing tune.


Jim,
Does phat have ideas on what could be causing the CEL to come on. I have phat dp and pulse tune. Next step would be sensor I guess??
User avatar
fatfrog02
 
Posts: 432
Joined: Fri May 16, 2008 8:17 am
Location: Blue Mts, Sydney NSW

Re: Engine light on with flashing cruise control light

Postby senator » Wed Apr 13, 2011 5:40 pm

fatfrog02 wrote:
Arith wrote:What makes this case unique is you're pretty much the only one who's gotten the dump pipe who has a pre-existing tune already. The tune may be optimised for a stock setup, and probably doesn't like the new addition. But it looks like your choices are limited, Adam. :?

1) Go back to the stock dump pipe
2) Get a re-tune
3) Replace the O2 sensors

All the choices seem to involve a bit of money. I would opt for choice 2 if I were you. You're only paying for a re-tune, and even the crappiest tuner re-tuning in the safest possible way would be better than your existing tune.


Jim,
Does phat have ideas on what could be causing the CEL to come on. I have phat dp and pulse tune. Next step would be sensor I guess??


your tune????? maybe with the cooler temps you might be over boosting.... I know Pulse had are few cars back wtih that issue when he first starting tuning our cars.
Not a soobi anymore, but still slightly dirty
"TEAM TONY"
User avatar
senator
 
Posts: 3217
Joined: Sun Apr 15, 2007 8:53 pm
Location: SYDNEY

Re: Engine light on with flashing cruise control light

Postby fatfrog02 » Wed Apr 13, 2011 7:24 pm

senator wrote:
your tune????? maybe with the cooler temps you might be over boosting.... I know Pulse had are few cars back wtih that issue when he first starting tuning our cars.


mmmm how do I get rid of the problem and stop it coming back? This is the first time I have had a CEL since the tune.
User avatar
fatfrog02
 
Posts: 432
Joined: Fri May 16, 2008 8:17 am
Location: Blue Mts, Sydney NSW

Re: Engine light on with flashing cruise control light

Postby senator » Thu Apr 14, 2011 11:46 am

fatfrog02 wrote:
senator wrote:
your tune????? maybe with the cooler temps you might be over boosting.... I know Pulse had are few cars back wtih that issue when he first starting tuning our cars.


mmmm how do I get rid of the problem and stop it coming back? This is the first time I have had a CEL since the tune.



Any soobi dealer or mechanic should be able to first read the error code (so you what the issue it) and then clear it
Not a soobi anymore, but still slightly dirty
"TEAM TONY"
User avatar
senator
 
Posts: 3217
Joined: Sun Apr 15, 2007 8:53 pm
Location: SYDNEY

Re:

Postby Synesthesia » Thu Apr 14, 2011 12:43 pm

gumbyy wrote:It may not even be the o2 sensor but yeh thats just what happened to my one.. i think it should be replaced under warranty. I believe our cars (mine at least) has a self diagnostic tool u can use to pull up the CEL code.. then google that code to find out exactly whats wrong. Use this link for instructions:

http://www.legacygt.com/forums/attachme ... 1127189539

Helped me find out my problem was an o2 sensor!

EDIT: The box should be located above or around your right knee when sitting in the drivers seat. The code should be displayed on your trip meter.


I have the CEL on and 'Cruise' on flash as well.

I just tried to pull the code using the guide in the link but as far as I can see I don't have that connector. I have an MY04 2.0GT. There was a loom with a white plug clipped into the socket by a yellow clip, and another socket & clip next to it. Should I be unplugging the loom from one socket and into the other? Or does anyone have a pic to show me what I should be doing on my particular model?
Image
Synesthesia
 
Posts: 7
Joined: Wed Mar 16, 2011 12:06 pm
Car: MY99 WRX & MY04 GT Premium
Real name: Adam

Re: Engine light on with flashing cruise control light

Postby Pyramidrocker » Sat Apr 30, 2011 9:15 am

I have the same problem flashing 'engine' light and 'cruise'. Had my local mechanic hook it up and it turns out it's the heater sensor. He cleared the error code and it's come back.
Anyone know if this is expencive to fix? Can i leave it for a while?
Cheers
2005 GT Liberty Wagaon, King Springs, 20'' K-Speed Biaggi's.
User avatar
Pyramidrocker
 
Posts: 61
Joined: Mon Aug 09, 2010 7:00 pm
Location: NSW South Coast
Car: 05 Liberty GT Wagon
Real name: Ben

Re: Engine light on with flashing cruise control light

Postby DJC » Fri May 06, 2011 3:10 pm

$300 to $500 should get your sensor installed and fix the problem of the flashing CEL and Cruise.
Search "O2 Sensor" to find one of the many threads in here about them.
:::MY04 Regal Blue Liberty GT Premium:::
|Lowered King Springs|KiDo ECU tune|HID conversion|HKS Filter|LEDs|Slotted rotors|TB Quad Tip exhaust|more TBA...
User avatar
DJC
-stickered-
 
Posts: 541
Joined: Tue Dec 02, 2008 4:00 pm
Location: Sydney
Car: MY04 GT Regal Blue Sedan
Real name: Ryan

Re: Engine light on with flashing cruise control light

Postby NA84WA » Tue May 10, 2011 12:47 am

Driving to work tonight sitting at 100kph with the cruise control on, CEL light came on, cruise light is flashing and [S] Mode is flashing.

Had Phat DP fitted and tune done last tuesday at All Star Garage at Perth. Ill have to give them a call tomorrow to see whats going on. Seems like quite a common problem!!

Has anyone found a permanant fix for this?
User avatar
NA84WA
 
Posts: 90
Joined: Wed Nov 03, 2010 5:22 pm
Location: Perth, WA
Car: Subaru Liberty MY08 GT Spec B
Real name: Nick
Profile URL: viewtopic.php?f=10&t=12211

Re: Engine light on with flashing cruise control light

Postby DJC » Thu May 12, 2011 4:07 pm

The post above should answer your question. ^^^
:::MY04 Regal Blue Liberty GT Premium:::
|Lowered King Springs|KiDo ECU tune|HID conversion|HKS Filter|LEDs|Slotted rotors|TB Quad Tip exhaust|more TBA...
User avatar
DJC
-stickered-
 
Posts: 541
Joined: Tue Dec 02, 2008 4:00 pm
Location: Sydney
Car: MY04 GT Regal Blue Sedan
Real name: Ryan

PreviousNext

Return to 2.5T engine specific

Who is online

Users browsing this forum: No registered users and 1 guest