'07 Liberty GT-B severe hesitation / Misfire

Posts specific to the 2.5 litre turbo engine

Re: '07 Liberty GT-B severe hesitation / Misfire

Postby bigBADbenny » Mon Sep 28, 2015 7:21 am

viewtopic.php?f=56&t=18219&p=416795#p416782

Start with a boost leak test.
I'll be making a smoke tester using basic auto and hardware store parts and a bike floor pump with psi gauge :)
User avatar
bigBADbenny
 
Posts: 8435
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: '07 Liberty GT-B severe hesitation / Misfire

Postby mpoli » Wed Nov 16, 2016 6:24 pm

Been getting the exact same issue as OP last few days. Havent got any error codes or anything but car is the same in the same rev ranges. Seems to boost about the same still but I did notice sitting on 110km in 5th it sounded a bit louder and pingy.
I took out maf and cleaned it but the dam rubber ring has broken in a few places so I just had to put plumbers tape in it for now until I can get one from sca or something since BP didnt have any :(
I will have to put in my obd2 thingy and go for a drive later, but im not really sure what to look for.
Possibly some issue with intercooler piping, i check the ones I can reach but not all of them since its fmic I think I might have to take it for a service.
User avatar
mpoli
 
Posts: 16
Joined: Tue Nov 04, 2014 12:51 am
Location: Adelaide, South Australia
Car: 07 Liberty GT tbSTI

Re: '07 Liberty GT-B severe hesitation / Misfire

Postby mpoli » Thu Nov 17, 2016 8:30 pm

Ended up disconnecting battery and resetting ecu, seem to run much better as it had some new learning time. Smell a bit carbony thou
I think been stuck for 1hr to get through 60metres of roadworks and people moving at 2-3km and hour in the 40 zone at the south rd roadworks was the reason....
Im so sick of that stupid section they make 1 lane, I have to go thru that to even do shopping :(
User avatar
mpoli
 
Posts: 16
Joined: Tue Nov 04, 2014 12:51 am
Location: Adelaide, South Australia
Car: 07 Liberty GT tbSTI

Re: '07 Liberty GT-B severe hesitation / Misfire

Postby bigBADbenny » Fri Nov 18, 2016 9:43 am

Check my tune faq link in my sig... It's a good start...
User avatar
bigBADbenny
 
Posts: 8435
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: '07 Liberty GT-B severe hesitation / Misfire

Postby jp928 » Fri Feb 03, 2017 4:19 pm

My idle went nuts high once in traffic, scared pants off! Coasting in nuetral it slowly lifted to ~1300 and held it. Once I got to work and thought about it, I disconnected the battery for several minutes, and reconnected. Problem has never recurred.

jp 08 gtb 6mt wagon.
jp928
 
Posts: 964
Joined: Fri Jan 04, 2008 9:27 am
Location: Melbourne
Car: 08 gtb 6mt wagon

Previous

Return to 2.5T engine specific

Who is online

Users browsing this forum: No registered users and 2 guests