CEL blinking 5th gen GT

Posts specific to the 2.5 litre turbo engine

CEL blinking 5th gen GT

Postby JakeC » Sat Sep 09, 2017 2:56 pm

Hi guys, driving from Bris to Sydney about 700km in and my CEL starts to blink. Pulled over, turned the car off and wait for NRMA to show up. Still blinking when the mechanic turns up, nothing seems to be wrong with the car, electronic diagnostic tool shows no error codes (even as the CEL is blinking). Start the car to have a listen, and CEL is gone, car runs normally. Start driving and 20k's down the road CEL starts flashing again (flashes for about 5 secs then dissapears for 3 or so, on a loop). Anyone seen this before or have an idea what's going on? Google search hasn't turned up any relevant results. Cheers!
JakeC
 
Posts: 11
Joined: Thu Nov 14, 2013 11:51 am
Car: MY10 Liberty GT

Re: CEL blinking 5th gen GT

Postby jslayz » Sat Sep 09, 2017 3:53 pm

It will be logging a code if CEL
NRMA code reader may not be up to it
CURRENT - ATP GTX 3576 - 22psi - 283.7awkw
OLD - Dom 1.5Xtr - Last dyno 254ahkw, previous 238ahkw, first 224awkw.
My journey thread: http://forum.liberty.asn.au/viewtopic.php?f=10&t=15523
My Lib Pics here: http://forum.liberty.asn.au/viewtopic.php?f=10&t=15523&start=570#p370656
User avatar
jslayz
 
Posts: 2807
Joined: Tue Mar 09, 2010 11:32 pm
Location: Perthhhhhh
Car: 2005 Liberty GT Wagon
Real name: J

Re: CEL blinking 5th gen GT

Postby fedaykin » Mon Sep 11, 2017 9:37 am

OBD2 reader can't be that hard, my $30 ebay one picked up the O2 sensor code and I cleared it a few times.
Maybe put a reader on it while the CEL is on/blinking?
fedaykin
 
Posts: 534
Joined: Wed Apr 08, 2015 10:09 am
Location: Sydney
Car: MY10 GT Wagon 6MT

Re: CEL blinking 5th gen GT

Postby superjoshism » Thu Sep 21, 2017 2:21 pm

Blinking CEL like that is probably a misfire. It's in the owners manual.
'09 MY10 Liberty GT Premium, 6MT, Pearl White
Summit Front Strut Bar | Cusco Rear Strut Bar | Whiteline F&R Swaybars | Kartboy F&R Endlinks | Eibach Pro-Kit Springs | Whiteline Anti-Lift | Whiteline Roll Centre Correction | Perrin Shifter Stop | Perrin Brass Shifter Bush | Perrin Short Shift Adapter | Perrin Steering Lockdown | STI GroupN Transmission Mount | Whiteline Positive Shift Bushes | Whiteline Rear Diff Inserts | Whiteline Rear Subframe Inserts | Whiteline LCA Bushes | Intake Resonator Delete | HKS Dump | GFB Respons BPV | DBA T2's | Goodridge Brake Lines

Build thread here
User avatar
superjoshism
 
Posts: 251
Joined: Thu Aug 21, 2014 10:17 pm
Location: Adelaide, SA
Car: MY10 Liberty GT Premium
Real name: Josh
Profile URL: viewtopic.php?f=10&t=27908

Re: CEL blinking 5th gen GT

Postby JakeC » Sat Dec 23, 2017 6:03 pm

Forgot to re-post after solving this problem (whoops), I will post here now in case anyone has a similar issue and finds this in a search.

Turns out it was an additional safety measure used by Matt from Kido in his tunes to warn the driver when exhaust temps are getting too high (sitting at 120 from Bris to Syd without stopping on a hot day will do this, apparently!). So if anyone with a Kido tune has a similar issue (rapid CEL blinks, no apparent change in car's performance and no result from OBD2 readers) let the car cool down fully and see if it disappears, this could be the cause! I've done Canberra to Bris and back since then and changed my driving style a bit, no re-occurrences so far (touch wood).

Also explains why the reader couldn't get a result and the CEL pattern didn't match anything from the manual/google.

Thanks for the replies everyone, my bad for the late post about the solution.
JakeC
 
Posts: 11
Joined: Thu Nov 14, 2013 11:51 am
Car: MY10 Liberty GT

Re: CEL blinking 5th gen GT

Postby superjoshism » Sat Dec 23, 2017 10:17 pm

JakeC wrote:Forgot to re-post after solving this problem (whoops), I will post here now in case anyone has a similar issue and finds this in a search.

Turns out it was an additional safety measure used by Matt from Kido in his tunes to warn the driver when exhaust temps are getting too high (sitting at 120 from Bris to Syd without stopping on a hot day will do this, apparently!). So if anyone with a Kido tune has a similar issue (rapid CEL blinks, no apparent change in car's performance and no result from OBD2 readers) let the car cool down fully and see if it disappears, this could be the cause! I've done Canberra to Bris and back since then and changed my driving style a bit, no re-occurrences so far (touch wood).

Also explains why the reader couldn't get a result and the CEL pattern didn't match anything from the manual/google.

Thanks for the replies everyone, my bad for the late post about the solution.


Oh, you failed to mention that in your initial post haha. I'm tuned by Matt too and I've had the same thing happen multiple times on long distance drives, usually about 3 hours in. You can 'clear' it by disconnecting the battery to reset the ECU but yeah the proper way is to let everything cool down.. :lol:
'09 MY10 Liberty GT Premium, 6MT, Pearl White
Summit Front Strut Bar | Cusco Rear Strut Bar | Whiteline F&R Swaybars | Kartboy F&R Endlinks | Eibach Pro-Kit Springs | Whiteline Anti-Lift | Whiteline Roll Centre Correction | Perrin Shifter Stop | Perrin Brass Shifter Bush | Perrin Short Shift Adapter | Perrin Steering Lockdown | STI GroupN Transmission Mount | Whiteline Positive Shift Bushes | Whiteline Rear Diff Inserts | Whiteline Rear Subframe Inserts | Whiteline LCA Bushes | Intake Resonator Delete | HKS Dump | GFB Respons BPV | DBA T2's | Goodridge Brake Lines

Build thread here
User avatar
superjoshism
 
Posts: 251
Joined: Thu Aug 21, 2014 10:17 pm
Location: Adelaide, SA
Car: MY10 Liberty GT Premium
Real name: Josh
Profile URL: viewtopic.php?f=10&t=27908

Re: CEL blinking 5th gen GT

Postby muzza » Sat Mar 10, 2018 8:07 pm

JakeC wrote:Forgot to re-post after solving this problem (whoops), I will post here now in case anyone has a similar issue and finds this in a search.

Turns out it was an additional safety measure used by Matt from Kido in his tunes to warn the driver when exhaust temps are getting too high (sitting at 120 from Bris to Syd without stopping on a hot day will do this, apparently!). So if anyone with a Kido tune has a similar issue (rapid CEL blinks, no apparent change in car's performance and no result from OBD2 readers) let the car cool down fully and see if it disappears, this could be the cause! I've done Canberra to Bris and back since then and changed my driving style a bit, no re-occurrences so far (touch wood).

Also explains why the reader couldn't get a result and the CEL pattern didn't match anything from the manual/google.

Thanks for the replies everyone, my bad for the late post about the solution.


Ok, interesting, I have a KiDo tune (mines auto) but never had an issue even fully loaded up the Hume at 110 in hot weather.
Mind you, I'm in Mexico, the land of a zillion speed cameras, so it's generally not smart to push it faster anywhere except remote back roads.... : :mrgreen:
Muzza
MY13 GT wagon auto.
Kido Tuned, STI quad-mufflers, Resonator-ectomy, GFB plumback BOV, SG Motorsport AOS, Perrin steering damper lockdown, grille, not finished yet....
User avatar
muzza
 
Posts: 468
Joined: Thu Apr 11, 2013 11:31 am
Location: Eastern Melbourne
Car: MY13 Liberty GT wagon
Real name: Murray

Re: CEL blinking 5th gen GT

Postby superjoshism » Tue Mar 13, 2018 8:01 pm

I know another local member who has had the same blinking CEL happen to him. After a few restarts it cools down and clears.

I spoke to Matt about it and he said it's fine to drive, it's more of a 'don't drive like a moron' light to let you know it's hot. Interestingly enough, it's designed to trigger when the difference between the coolant temp sensors is larger than usual - indicating the turbo is getting warm. This means it can happen in 'cold' weather too, it's just not likely.
'09 MY10 Liberty GT Premium, 6MT, Pearl White
Summit Front Strut Bar | Cusco Rear Strut Bar | Whiteline F&R Swaybars | Kartboy F&R Endlinks | Eibach Pro-Kit Springs | Whiteline Anti-Lift | Whiteline Roll Centre Correction | Perrin Shifter Stop | Perrin Brass Shifter Bush | Perrin Short Shift Adapter | Perrin Steering Lockdown | STI GroupN Transmission Mount | Whiteline Positive Shift Bushes | Whiteline Rear Diff Inserts | Whiteline Rear Subframe Inserts | Whiteline LCA Bushes | Intake Resonator Delete | HKS Dump | GFB Respons BPV | DBA T2's | Goodridge Brake Lines

Build thread here
User avatar
superjoshism
 
Posts: 251
Joined: Thu Aug 21, 2014 10:17 pm
Location: Adelaide, SA
Car: MY10 Liberty GT Premium
Real name: Josh
Profile URL: viewtopic.php?f=10&t=27908


Return to 2.5T engine specific

Who is online

Users browsing this forum: No registered users and 2 guests