Rough Idle Yet Again

Posts specific to the 2.0 litre Turbo engine

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Thu Nov 02, 2017 4:18 pm

Updating so if someone else is in the same situation this might help them. OCV checked and they are working as they should. Pointing towards fuel injectors at this point and next step will be to get them cleaned plus swap the fuel filter. Probably worth getting them flow tested at the same time imo. Will post further updates.
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby bigBADbenny » Fri Nov 03, 2017 5:32 am

Is it tuned?
User avatar
bigBADbenny
 
Posts: 8105
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Tue Nov 07, 2017 6:10 pm

Yes tuned 2weeks ago by Matt from Kidotune.
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby bigBADbenny » Tue Nov 07, 2017 9:22 pm

Where you unable to recreate the issue during the tuning session?
User avatar
bigBADbenny
 
Posts: 8105
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: Rough Idle Yet Again

Postby jslayz » Tue Nov 07, 2017 11:56 pm

Do you have stock fuel system?
Dampers etc...?
check the line to FPR too?
CURRENT - ATP GTX 3576 - 22psi - 283.7awkw
OLD - Dom 1.5Xtr - Last dyno 254ahkw, previous 238ahkw, first 224awkw.
My journey thread: http://forum.liberty.asn.au/viewtopic.php?f=10&t=15523
My Lib Pics here: http://forum.liberty.asn.au/viewtopic.php?f=10&t=15523&start=570#p370656
User avatar
jslayz
 
Posts: 2776
Joined: Tue Mar 09, 2010 11:32 pm
Location: Perthhhhhh
Car: 2005 Liberty GT Wagon
Real name: J

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Wed Nov 08, 2017 4:37 pm

Yes the idle was fluctuating when it came to a stop. No fault of his but Matt thought it could have been the o2 sensor based on the readings he was getting.
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Wed Nov 08, 2017 4:40 pm

Stock fuel system for now.
No dampers.
Quick look at lines to the fuel pressure regulator seem fine.
It's got fuel pressure but the injectors might be fouled.
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby bigBADbenny » Wed Nov 08, 2017 5:30 pm

So if the idle fluctuates when parked, try gently clamping the fuel return line, post fpr.
Eg using the yellow plastic clamps with variable lock (sca or repco).
Throttle bodies are known to crap out as well.
User avatar
bigBADbenny
 
Posts: 8105
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Fri Nov 10, 2017 11:07 am

Thanks i'll give it a shot and post an update.
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby bigBADbenny » Fri Nov 10, 2017 12:23 pm

I'd also use a screwdriver as a stethoscope on each of the injectors at idle to see if I could hear a diffence in the clicking.
Also reading the sparkplugs may indicate if one cylinder is too lean or rich...
If new or refurb injectors are required, that's an opportunity to get silicone inlet & tb hose in at the same time.
User avatar
bigBADbenny
 
Posts: 8105
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Fri Nov 17, 2017 7:34 am

Update - Problem seems to have been solved but i need to give it a couple more days to be certain. Fuel filter changed and injectors removed to do a proper professional clean. Idle is finally back to normal. Hope it helps others.

Thanks to everyone that chimed in with what the symptoms could be pointing towards. Much appreciated!!
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Previous

Return to 2.0T engine specific

Who is online

Users browsing this forum: No registered users and 1 guest