Rough Idle Yet Again

Posts specific to the 2.0 litre Turbo engine

Rough Idle Yet Again

Postby 04_LibertyGT » Fri Jan 27, 2017 3:55 pm

Hi all I'm new to the forum and I have used the search engine for rough idles. It seems to be a well documented subject but instead of searching for a fault that a lot of people seem to struggle with due to the many potential faults, I have decided to get an independent Subaru specialist to take a look at it.

There were a couple of guys recommended on here but I decided to go with Lucas Automotive in the hope they can data log the issue and start diagnosing. They seemed knowledgeable over the phone as you would expect from a specialist. I previously used Tony from URD Automotive and he was great and I would highly recommend him if you are out Knox way. However, I had a wrx at the time plus Lucas Automotive is closer and gets a good rep on here.

Anyway mine is an auto 04 Liberty GT with 180kms on the clock and the rough idle is when stopped both in drive or neutral. It almost wants to stall when coming to a stop sometimes and the idle issue is when engine temps are both cold or hot. I bought the car with the idle issue and it didn't develop whilst I owned it.

If they find the fault, I'll post the issue in the hope this can one day help someone else.

Thanks!
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby bigBADbenny » Fri Jan 27, 2017 10:37 pm

Happy to log n lv in Melb :)
User avatar
bigBADbenny
 
Posts: 8247
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Sat Jan 28, 2017 9:37 am

Thanks Benny. Pm sent.
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby Bigwillystyle » Sun Jan 29, 2017 6:55 am

Hi buddy,

Welcome to the club..

We fixed mine yesterday.. Was smooth for 30 seconds and then rough. Give it some Jandal and ot would come good and rough as it dropped to a stall at times..

Turned out to be lack of fuel pressure caused by a oring that was pinched in the fuel filter.. For that matter I wouldn't discount the fuel filter at those klms either..

May or may not solve your issue but checking fuel pressure by grabbing the rubber fuel lines under bonnet was what gave it away.. especially when the scan shows no faults
Bigwillystyle
 
Posts: 4
Joined: Mon Sep 12, 2016 10:32 pm
Car: 04 Gt liberty wagon

Re: Rough Idle Yet Again

Postby GTWAGON06 » Sun Jan 29, 2017 4:15 pm

I have the exact same issue with my 05 at the moment. Driving me nuts! Cant get any to figure out what the problem is!
GTWAGON06
 
Posts: 6
Joined: Tue Aug 09, 2016 9:06 pm

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Sun Jan 29, 2017 9:46 pm

Thanks i'll get the fuel pressure and vacuum leak checked at the same time. It has been driving me crazy as well but so many potential faults. I would rather let someone with the expertise look at it as I could be chasing this forever. I'll post up what the issue is once i know. I'm booked in for next week.
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby bigBADbenny » Wed Feb 01, 2017 6:07 am

Also worth checking the fuel pump plug pins under the rear seat below a screwed on cover, look for burnt pins in the connector..
User avatar
bigBADbenny
 
Posts: 8247
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Fri Feb 03, 2017 1:26 pm

Thanks i'll take a look over the weekend.
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Tue Feb 07, 2017 7:31 am

Just picked the car up and the potential list is -
Plugs
Injectors
Timing issue

The guys were helpful and great breakdown of potential issues in detail but i'll need to do some work to keep cost down.

I'll do the plugs over the weekend as i don't know the history of the car and its a good starting point. Since its not throwing any codes they advised to wait but this rough idle is really bugging me. I'll do plugs first then if that fails, I'll pull out the injectors to get them tested/cleaned.

I also wonder if the K&N panel filter could have been over oiled by the previous owner and damaged the afm. I have tried contact cleaner to no avail. I know they are really sensitive to oil on the wrx and cleaning doesn't help. Probably changed 2 in 7yrs of owning a wrx.

Suggestions welcome.
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby bigBADbenny » Tue Feb 07, 2017 4:23 pm

Ditch the k&n go stock filter n box if everything else is stock, crc maf cleaner on the afm and check the o ring is sealing & not pinched.
User avatar
bigBADbenny
 
Posts: 8247
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Sun Feb 12, 2017 9:56 am

New plugs went in and cleaned the maf with crc cleaner but still not fixed. Also took the opportunity to do a top engine cleaner spray, dropped the oil and changed the oil filter.

At this point I think its injectors, from what i read on here they are a common issue along with wheel bearings on libertys. I'll clean the throttle body when i remove the injectors just in case its sticking as well.

Does anyone have recommendations for an injector cleaning place in the SE suburbs?? I would want them flow tested after cleaning and would have to be cheaper than buying new ones.
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Sun Feb 12, 2017 4:08 pm

Update - Stalled twice today. Once when sitting at the lights and the second time was scary in a turn. It shut down, I lost power steering and barely managed the turn without mounting the curb. This is getting dangerous.
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby Surge » Sun Feb 12, 2017 6:37 pm

Bigwillystyle wrote:Hi buddy,

Welcome to the club..

We fixed mine yesterday.. Was smooth for 30 seconds and then rough. Give it some Jandal and ot would come good and rough as it dropped to a stall at times..

Turned out to be lack of fuel pressure caused by a oring that was pinched in the fuel filter.. For that matter I wouldn't discount the fuel filter at those klms either..

May or may not solve your issue but checking fuel pressure by grabbing the rubber fuel lines under bonnet was what gave it away.. especially when the scan shows no faults


I'd second this.

Change your fuel pump and filter. Ensure you use the correct size o-rings in the correct location.
DIY romraider E85 tuned Subaru liberty GT Premium 2010 Auto.
New project: Lexus Soarer 2.5gtt jzz30 1992

[ACT]Free Tune help- Learning view, Romraider, ECU Flash
User avatar
Surge
 
Posts: 789
Joined: Sat Dec 08, 2012 1:28 pm
Location: ACT
Car: 2010 lib GT premium + Jzz30 soarer

Re: Rough Idle Yet Again

Postby 04_LibertyGT » Sun Feb 12, 2017 7:22 pm

Thanks for the input. I'll try the lines under the bonnet. Unfortunately fuel pressure wasn't tested last time it was in the shop but i'll drop it off this week. From what i know the fuel filter is part of the whole fuel pump assembly with the liberty??
04_LibertyGT
 
Posts: 38
Joined: Fri Jan 27, 2017 3:35 pm
Car: 2004 Subaru Liberty GT

Re: Rough Idle Yet Again

Postby bigBADbenny » Mon Feb 13, 2017 5:57 am

Great idea^^, also gives you the opp to check the fuel pump top loom connector, and the connectors below: the plug is a known failure point - look for a burnt pin.
User avatar
bigBADbenny
 
Posts: 8247
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Next

Return to 2.0T engine specific

Who is online

Users browsing this forum: No registered users and 2 guests