Rough idle and stall only when stopped.

Posts specific to the 2.0 litre Turbo engine

Re: Rough idle and stall only when stopped.

Postby bigBADbenny » Wed May 13, 2015 5:23 pm

Read up on the latest :)

viewtopic.php?f=18&t=20233&start=345
viewtopic.php?f=6&t=30056

You're best off buying or borrowing a btssm or tactrix, getting a full diagnosis of inlet and exhaust vvt, and replacing one or both or all OCV's.
Cleaning them is usually only a temporary fix.

Do that and get tuned for the best result :)
User avatar
bigBADbenny
 
Posts: 8305
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: Rough idle and stall only when stopped.

Postby Gyro Gearloose » Mon May 25, 2015 7:31 am

I had an issue where my GT would hunt and surge when stopped at lights ect. Used BTSSM to check AVCS and it was working as it should, but the air fuel ratio was varying all over the place in time with the hunting so I replaced the oxygen sensor and problem fixed
2004 Liberty GT Auto
2004 Forester
1987 Leone RX Turbo with EJ20G, 5sp AWD Dual Range and WRX brakes (Khanacross Toy)
User avatar
Gyro Gearloose
 
Posts: 64
Joined: Tue Jan 17, 2012 5:48 pm
Location: Nambucca
Car: 04 Liberty GT Auto, 87 Leone RX
Real name: Gannon

Re: Rough idle and stall only when stopped.

Postby Tommyt1 » Thu Sep 14, 2017 12:30 am

Hi guys got the exact same problem with my lib 2.0gt. I'm getting intake hose replaced. Fault code came up on air intake leak. Hopefully that will fix the problem.
Tommyt1
 
Posts: 37
Joined: Fri Sep 08, 2017 11:30 pm
Car: Subaru liberty gt MY05
Real name: Tommy

Re: Rough idle and stall only when stopped.

Postby bigBADbenny » Thu Sep 14, 2017 6:01 am

Gyro Gearloose wrote:I had an issue where my GT would hunt and surge when stopped at lights ect. Used BTSSM to check AVCS and it was working as it should, but the air fuel ratio was varying all over the place in time with the hunting so I replaced the oxygen sensor and problem fixed


Logging should be the first step, then physical tests, then make repairs or replaments.
User avatar
bigBADbenny
 
Posts: 8305
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Previous

Return to 2.0T engine specific

Who is online

Users browsing this forum: No registered users and 2 guests