3.0R Severe power loss

Posts specific to the 3.0 litre NA H6 engine

3.0R Severe power loss

Postby williamhowe_888 » Wed Aug 02, 2017 2:24 pm

Hi All,

Having some troubles with my 2006 3.0R and was hoping the hive mind could provide some information. I seem to have lost a lot of power, especially at the low end when accelerating hard (under 3500RPM). The rev's go up through the range, but the car is just not moving. There appears to be nothing else wrong with the car either, though I have noticed a slight ticking/tapping noise from the left hand side over the past week, though this has not gotten any worse and was not around when I started having my initial power issues. I have it booked in to pop on a dyno to test emissions to see if a cat is blocked (this has happened to me before on other cars, very similar issue), but apart from that, no other ideas come to mind. Any assistance would be great!

Cheers,
Will
williamhowe_888
 
Posts: 5
Joined: Thu Jul 03, 2014 12:14 pm

Re: 3.0R Severe power loss

Postby Surge » Wed Aug 02, 2017 4:58 pm

If the revs are going up but your speed isn't, then it sounds like the transmission I'd slipping.

Auto or manual.

Ticking when turning left could be many things, bad centre diff, Bad CV, bad strut tops or other suspension components.
DIY romraider E85 tuned Subaru liberty GT Premium 2010 Auto.
New project: Lexus Soarer 2.5gtt jzz30 1992

[ACT]Free Tune help- Learning view, Romraider, ECU Flash
User avatar
Surge
 
Posts: 789
Joined: Sat Dec 08, 2012 1:28 pm
Location: ACT
Car: 2010 lib GT premium + Jzz30 soarer

Re: 3.0R Severe power loss

Postby williamhowe_888 » Thu Aug 03, 2017 8:29 am

Hi Surge,

Cheers for the response. It's an engine related noise, not suspension, it changes pitch with the revs unfortunately. Also, it's not transmission slippage either, that's pretty noticeable. I can do hard launches without any issues (a good way to test clutch slipping). It's a manual 6 speed as well.

Cheers,
Will Howe
williamhowe_888
 
Posts: 5
Joined: Thu Jul 03, 2014 12:14 pm

Re: 3.0R Severe power loss

Postby Surge » Thu Aug 03, 2017 11:46 am

Have you tried leaving the battery disconnected long enough for the ECU to reset.

That can sometimes help ID the issue.
DIY romraider E85 tuned Subaru liberty GT Premium 2010 Auto.
New project: Lexus Soarer 2.5gtt jzz30 1992

[ACT]Free Tune help- Learning view, Romraider, ECU Flash
User avatar
Surge
 
Posts: 789
Joined: Sat Dec 08, 2012 1:28 pm
Location: ACT
Car: 2010 lib GT premium + Jzz30 soarer

Re: 3.0R Severe power loss

Postby tom_kauf » Thu Aug 31, 2017 2:23 pm

Hi Will, have you got access to an OBDII reader? That'll tell you a lot about the health of the engine. You mentioned a ticking noise, could it bad bad fuel causing pinging?
[Stealth & Speed - Comfort & Practicality]: My 2008 MY09 GT SpecB Wagon - Manual 185,000km
User avatar
tom_kauf
-stickered-
 
Posts: 1327
Joined: Thu Sep 26, 2013 1:05 pm
Location: Brisbane, QLD
Car: 2008 Liberty GT SpecB Manual Wagon
Real name: Tom

Re: 3.0R Severe power loss

Postby KiDo_Tuning » Mon Sep 04, 2017 5:27 pm

If RPM goes up and engine speed does not go up at the same rate(say 2000rpm at 80kph should be 120 at 3000rpm etc) then your clutch is slipping

Video of what is happening?
KiDo Racing Tunes Info: HERE

Great minds discuss ideas;
Average minds discuss events;
Small minds discuss people
User avatar
KiDo_Tuning
 
Posts: 2798
Joined: Sun Jun 10, 2012 11:53 pm
Car: Subarus + Nissans
Real name: Matt


Return to 3.0R & 3.6R engine specific

Who is online

Users browsing this forum: No registered users and 2 guests