Rear drive not working on BL 2.5 auto 2005

Posts specific to the 2.5 litre NA engine

Rear drive not working on BL 2.5 auto 2005

Postby Clearlight » Tue Mar 01, 2016 2:58 pm

Took off from traffic lights today in the rain and got wheelspin ! Never happened before other than a half wheel
rotation before the rear drive kicked in . Did a standing start on a wet hill and definitely no rear drive , front
only drive .
Without taking it to a dealer and dropping my pants for the inevitable reaming , what should I look for in terms
of loose wires , fuses etc ? there are no 4wd warning lights on the dash and car drives fine other than no rear drive .
Clearlight
 
Posts: 22
Joined: Wed Jan 27, 2016 11:19 pm
Location: brisbane
Car: Liberty BL

Re: Rear drive not working on BL 2.5 auto 2005

Postby kiahatsiu » Wed Mar 02, 2016 7:44 am

Operations normal. Open front diff. It is what they do.
Kinda flush. Fitment is something. ADM as F*ck.
User avatar
kiahatsiu
 
Posts: 1795
Joined: Tue Sep 01, 2009 6:09 pm
Location: Brisbane
Car: Silver 05 GT Wagon
Real name: Ian

Re: Rear drive not working on BL 2.5 auto 2005

Postby ElCoyote » Wed Mar 02, 2016 12:06 pm

Solenoid on centre diff. Colour coded so be careful
Last edited by ElCoyote on Thu Mar 03, 2016 7:18 am, edited 1 time in total.
User avatar
ElCoyote
 
Posts: 6
Joined: Wed Nov 05, 2014 9:05 am
Location: Auckland NZ
Car: legacy 07 3.0R

Re: Rear drive not working on BL 2.5 auto 2005

Postby Clearlight » Wed Mar 02, 2016 12:51 pm

Definitely not normal . Its a na auto , full throttle starts on loose gravel used to generate half a front wheel
rotation of spin before the rear drive kicked in then the car just accelerated with no spin .
Now under the same condition , its just bags up the front wheels and goes nowhere .

Can anyone recommend a Subaru specialist workshop in Brisbane ? Maybe they can do the head gaskets
at the same time ; and the CEL codes and …. This BL is getting expensive ….
AS a temporary fix , Ive put the ' flat tyre fuse in place for 2wd operation . Hope thats ok ?
Clearlight
 
Posts: 22
Joined: Wed Jan 27, 2016 11:19 pm
Location: brisbane
Car: Liberty BL

Re: Rear drive not working on BL 2.5 auto 2005

Postby WIDELOAD » Thu Mar 03, 2016 7:44 am

Clearlight wrote:Definitely not normal . Its a na auto , full throttle starts on loose gravel used to generate half a front wheel
rotation of spin before the rear drive kicked in then the car just accelerated with no spin .
Now under the same condition , its just bags up the front wheels and goes nowhere .

Can anyone recommend a Subaru specialist workshop in Brisbane ? Maybe they can do the head gaskets
at the same time ; and the CEL codes and …. This BL is getting expensive ….
AS a temporary fix , Ive put the ' flat tyre fuse in place for 2wd operation . Hope thats ok ?


Where is Brissy are you?

You've got John French Motors @ the Gabba, Boxer Service @ Brendale, Scorpion @ Capalaba, Rising Sun Subaru & AM Auto on the Sunny coat, prob a few others I've missed.

My parents have used John French since the mid 90s, I've always used them too. Top guys, zero fucking about, and brutally honest.
User avatar
WIDELOAD
 
Posts: 392
Joined: Sat Apr 06, 2013 7:54 pm
Location: Ipswich, QLD
Car: MY08 GT Spec B
Real name: Troy

Re: Rear drive not working on BL 2.5 auto 2005

Postby alexeiwoody » Thu Mar 03, 2016 9:17 am

Those are the text book symptoms of a broken Centre Diff.

If it also clunks while turning, you've got some broken gears in there 100%
Running no. of weeks without breaking something in the lib: 0
No. of things still to fix in in the lib: 43
User avatar
alexeiwoody
 
Posts: 1897
Joined: Thu Jul 12, 2012 11:47 pm
Location: Melbourne
Car: MY07 LibGT 5EAT
Real name: Alexei

Re: Rear drive not working on BL 2.5 auto 2005

Postby Clearlight » Thu Mar 03, 2016 9:51 pm

Ok no clunking on turns , as its an auto I suspect its the clutch pack on the back of the box . When i put
the flat tyre fuse in for 2wd operation , it decoupled the rear drive completely reducing the little bit
of drag I felt . Guess that means the solenoid that operates that system is working , but the clutch pack
is rooted . The auto trans works perfectly with no problems .

I bought the car with 150k clicks on the odo , and Ive been driving it most enthusiastically so I'm not
too pissed off .
I will go see Frenchy , I think I saw his wife's old Alfa Romeo Montreal driving up Abbortsford Rd the
other day . On the bright side , the Liberty is easier to fix than one of those …..
Clearlight
 
Posts: 22
Joined: Wed Jan 27, 2016 11:19 pm
Location: brisbane
Car: Liberty BL

Re: Rear drive not working on BL 2.5 auto 2005

Postby WIDELOAD » Fri Mar 04, 2016 7:45 am

Clearlight wrote:I will go see Frenchy , I think I saw his wife's old Alfa Romeo Montreal driving up Abbortsford Rd the
other day . On the bright side , the Liberty is easier to fix than one of those …..


Yep. That would be her old one. Bloody beautiful thing.
I remember when it used to sit in display at the old show room across from the Red Brick Hotel.

Frenchy isn't at the workshop much these days other than to chinwag. Andrew is the head honcho there, top bloke.
User avatar
WIDELOAD
 
Posts: 392
Joined: Sat Apr 06, 2013 7:54 pm
Location: Ipswich, QLD
Car: MY08 GT Spec B
Real name: Troy

Re: Rear drive not working on BL 2.5 auto 2005

Postby Clearlight » Fri Mar 04, 2016 9:34 am

WIDELOAD wrote:
Clearlight wrote:I will go see Frenchy , I think I saw his wife's old Alfa Romeo Montreal driving up Abbortsford Rd the
other day . On the bright side , the Liberty is easier to fix than one of those …..


Yep. That would be her old one. Bloody beautiful thing.
I remember when it used to sit in display at the old show room across from the Red Brick Hotel.

Frenchy isn't at the workshop much these days other than to chinwag. Andrew is the head honcho there, top bloke.


Yes indeed . Quad cam 2.6 v8 with dry sump and mechanical sequential injection that compensates for temp and altitude ,
as well as rpm and load . Amazing analogue technology no computers !
Clearlight
 
Posts: 22
Joined: Wed Jan 27, 2016 11:19 pm
Location: brisbane
Car: Liberty BL


Return to 2.5i engine specific

Who is online

Users browsing this forum: No registered users and 2 guests