Engine Misfire/cut out going uphills

Posts specific to the 2.0 litre NA engine

Engine Misfire/cut out going uphills

Postby ibells » Mon Aug 31, 2015 3:13 pm

I have a 1993 Liberty 2.2 that every time you go up a long hill it starts running rough and some times cut out.
I pull over and wait two or three minutes and start it back up and runs fine again until the next long hill.
I have changed the spark plug, leads, air filter, and ignition relay.
I did a fuel pressure test and it seems fine, when I am going up hill the fuel pressure runs between 40 to 45 psi.
It also seems to use a lot of fuel.
Any one have any ideas why this may happen.
Thanks.
ibells
 
Posts: 1
Joined: Mon Aug 31, 2015 2:13 pm
Car: 1993 liberty

Re: Engine Misfire/cut out going uphills

Postby BillyCorgi » Mon Aug 31, 2015 3:33 pm

Look at this thread.
There seems to be a common issue with the 2.2 litre engine (with Hydraulic valve lash adjustment) and loss of power?
viewtopic.php?f=45&t=13950&p=188969&hilit=lifters+pumping+up#p188969
Get your Short Shift Adaptor viewtopic.php?f=68&t=30525
Get your Gear Shift Rejuvenation Kit viewtopic.php?f=68&t=31240
Get your Centre Differential Rebuild viewtopic.php?f=6&t=31089
Want a custom built Brake Cylinder Stopper? viewtopic.php?f=6&t=31321
Need to hire a Guard Rolling Machine? viewtopic.php?f=6&t=31899
Get your BillyCorgi's "Not-4-Wimps" Chilli Sauce
User avatar
BillyCorgi
 
Posts: 1583
Joined: Tue Aug 20, 2013 10:11 pm
Location: Bankstown Area, Sydney
Car: Liberty 3.0R-B Wagon E85 Flex Fuel
Real name: Peter
Profile URL: www.facebook.com/CorgiWerx


Return to 2.0R engine specific

Who is online

Users browsing this forum: No registered users and 1 guest