GEN4 liberty Secondary air pump Issues...

Posts specific to the 2.0 litre NA engine

GEN4 liberty Secondary air pump Issues...

Postby mick86 » Mon Sep 01, 2014 10:01 pm

okay, so I bought a 2005 liberty sedan in early feb this year. It only had 120ks on the clock, And looked seemed really well looked after. Its one of the Yellow limited edition models. but yeah, since buying it from a Holden dealership on the south coast, its had 5 second hand air pumps and valves installed. and just over a month ago a brand new one installed by Subaru costing $3800. And yet the issue still exists. Within just a few days after the parts are installed the engine light reappears, and cruise control is deactivated. Subaru told me the issue would be fixed if i got them to install new Genuine parts and if they did the work. But no. All has been paid for by Holden, under their statutory warranty but now they say they've done all they can. I have been driving around a holden courtesy car, until they can work out whether to get me into another car or give me a full refund. I don't want another car, I just want it fixed.

Has anyone else had this issue? I've had the car at 3 Subaru dealers and they all seem like they have no idea of the cause.
User avatar
mick86
 
Posts: 14
Joined: Mon Sep 01, 2014 9:41 pm
Car: 05 Gen4 Liberty
Real name: mick

GEN4 liberty Secondary air pump Issues...

Postby jaydece » Tue Sep 02, 2014 2:29 pm

From my understanding it's only for start up (emissions) - just disable the cel in the tune and don't spend any more $$$$ - I believe this will solve your problem...could be wrong? Any other suggestions or inputs people?...

All my air pumps have been removed and all related cels in the tune disabled...never had any issues...Just remember if you decide to remove the whole air pump system to keep the atmopheric sensor plugged in....or else the car will think it's under water and wont run correctly....

So having said above? just put back your original one...or keep the latest one thats been installed.....edit your tune and disable all related CELS to air pump..

Sent from my iPhone using Tapatalk
~JUSZTN~

** Our Turbo Lag Gives Those v8's A Chance **

Past - MY07 Liberty TBSTI 6SPD Sedan
265kw atw on P100
290kw atw on E85(fuel pump limited)


Past - MY16 Audi S3 Sedan

Present - MY18 Audi RS3 Sedan (His)
Present - MY17 VW Tiguan 162 R line (Hers)
User avatar
jaydece
 
Posts: 1627
Joined: Fri Apr 23, 2010 11:21 pm
Location: VIC, Berwick 3806
Car: MY18 Audi RS3 Sedan 7 SPD DSG
Real name: Justin
Profile URL: viewtopic.php?f=10&t=11864

Re: GEN4 liberty Secondary air pump Issues...

Postby mick86 » Mon Oct 20, 2014 9:22 pm

Luckily I haven't spent any money on the issue, it's all warranty work by a holden dealership, who I bought the car off 6 months ago. But I just picked it up from them today. They've had it for 7weeks total again. They said they believe the issue is fixed. Manager told me they upgraded the CPU. And the Forman told me they didn't, it was just a loose wiring harness behind the computer causing the issue.... So I really don't know what they have done. Hopefully nothing dodgy.

But apparently, coz it's the 2.0L it can't be disabled in a tune.. So I've been told by a couple of ppl. Apparently If it was another model they said yeah that could be done. But I dunno. Hoping it's all sorted finally.. :-/
User avatar
mick86
 
Posts: 14
Joined: Mon Sep 01, 2014 9:41 pm
Car: 05 Gen4 Liberty
Real name: mick

Re: GEN4 liberty Secondary air pump Issues...

Postby bigBADbenny » Mon Oct 20, 2014 9:49 pm

I'd recommend a tune regardless, and get the air pump cel issue sorted at the same time :)
Iirc Matt throttlehappy / kido can tune the hitachi Ecu now...

Keep us posted with developments :)
User avatar
bigBADbenny
 
Posts: 8482
Joined: Tue Oct 04, 2011 6:36 pm
Location: Collingwood, Melbourne
Car: MY07 GT-B 6MT OBP Wagon
Real name: Ben Richards
Profile URL: http://tinyurl.com/agvbzop

Re: GEN4 liberty Secondary air pump Issues...

Postby KiDo_Tuning » Mon Oct 20, 2014 10:03 pm

Can now be tuned and disabled :) Not cheap and it would be around 3 weeks without the car BUT it can be done

Fingers crossed for the near future though
KiDo Racing Tunes Info: HERE

Great minds discuss ideas;
Average minds discuss events;
Small minds discuss people
User avatar
KiDo_Tuning
 
Posts: 2798
Joined: Sun Jun 10, 2012 11:53 pm
Car: Subarus + Nissans
Real name: Matt

Re: GEN4 liberty Secondary air pump Issues...

Postby Deep Heat » Tue Oct 21, 2014 2:04 am

KiDo_Tuning wrote:Can now be tuned and disabled :) Not cheap and it would be around 3 weeks without the car BUT it can be done

Fingers crossed for the near future though


Nice marketing. Only just discovered how to solider and burn chips?
Jack_Keaka wrote: I like my women like subarus, box explodes and does a head easily.
Deep Heat
formerly Twinkle
 
Posts: 1403
Joined: Mon Sep 09, 2013 10:01 pm
Location: Kellyville, NSW

Re: GEN4 liberty Secondary air pump Issues...

Postby KiDo_Tuning » Tue Oct 21, 2014 8:27 pm

Deep Heat wrote:
KiDo_Tuning wrote:Can now be tuned and disabled :) Not cheap and it would be around 3 weeks without the car BUT it can be done

Fingers crossed for the near future though


Nice marketing. Only just discovered how to solider and burn chips?


Seen a late model Hitachi ECU? This is not a Unisia JECS / Hitachi Nissan ECU or a VL Turbo ECU that I was burning chips and soldering in sockets for in the early 90's :roll:

They have flashable memory BUT never had Tactrix support(still dont have official Tactrix support!)
KiDo Racing Tunes Info: HERE

Great minds discuss ideas;
Average minds discuss events;
Small minds discuss people
User avatar
KiDo_Tuning
 
Posts: 2798
Joined: Sun Jun 10, 2012 11:53 pm
Car: Subarus + Nissans
Real name: Matt

Re: GEN4 liberty Secondary air pump Issues...

Postby mick86 » Thu Nov 06, 2014 9:58 am

So car was at a "subaru specialist " for 8 weeks and 5 days. They said that they found a loose wiring harness. And did some work to the computer. Apparently I wouldn't have the issue again. But 5 days later engine light re-appears.. This car is obviously a dud. Should have noticed by the yellow it was a lemon.
User avatar
mick86
 
Posts: 14
Joined: Mon Sep 01, 2014 9:41 pm
Car: 05 Gen4 Liberty
Real name: mick

Re: GEN4 liberty Secondary air pump Issues...

Postby mick86 » Wed Nov 26, 2014 8:34 am

still having engine light issue. spoke to MRT in Sydney and they say they cant tune the car. because the 2.0R model has a different computer to the other models. my only option now it seems, is to have Subaru in town, pull apart the engine and decarbonise. they think this is what is causing the issue. but im thinking it will be a waste of almost $3000. and by the looks of it, no one else has had this same issue. normally u replace the pump and your all sorted. but in my case pumps been replaced on 5 occasions and light fault code returns. annoying.
User avatar
mick86
 
Posts: 14
Joined: Mon Sep 01, 2014 9:41 pm
Car: 05 Gen4 Liberty
Real name: mick

Re: GEN4 liberty Secondary air pump Issues...

Postby KiDo_Tuning » Wed Nov 26, 2014 4:07 pm

mick86 wrote:still having engine light issue. spoke to MRT in Sydney and they say they cant tune the car. because the 2.0R model has a different computer to the other models. my only option now it seems, is to have Subaru in town, pull apart the engine and decarbonise. they think this is what is causing the issue. but im thinking it will be a waste of almost $3000. and by the looks of it, no one else has had this same issue. normally u replace the pump and your all sorted. but in my case pumps been replaced on 5 occasions and light fault code returns. annoying.


Doing one right now actually. The airpump issue is failing a cold start emissions test. Disable the codes, sorted since a 8+yr old car does not need an emissions test as long as it has a catalytic converter
KiDo Racing Tunes Info: HERE

Great minds discuss ideas;
Average minds discuss events;
Small minds discuss people
User avatar
KiDo_Tuning
 
Posts: 2798
Joined: Sun Jun 10, 2012 11:53 pm
Car: Subarus + Nissans
Real name: Matt

Re: GEN4 liberty Secondary air pump Issues...

Postby mick86 » Mon Dec 15, 2014 11:16 am

KiDo_Tuning wrote:
mick86 wrote:still having engine light issue. spoke to MRT in Sydney and they say they cant tune the car. because the 2.0R model has a different computer to the other models. my only option now it seems, is to have Subaru in town, pull apart the engine and decarbonise. they think this is what is causing the issue. but im thinking it will be a waste of almost $3000. and by the looks of it, no one else has had this same issue. normally u replace the pump and your all sorted. but in my case pumps been replaced on 5 occasions and light fault code returns. annoying.


Doing one right now actually. The airpump issue is failing a cold start emissions test. Disable the codes, sorted since a 8+yr old car does not need an emissions test as long as it has a catalytic converter




I have been to a couple dyno tune places. Both have said cannot be done on this model car. So now I am getting a full pull apart and carbon clean out done by subaru.
User avatar
mick86
 
Posts: 14
Joined: Mon Sep 01, 2014 9:41 pm
Car: 05 Gen4 Liberty
Real name: mick

Re: GEN4 liberty Secondary air pump Issues...

Postby KiDo_Tuning » Mon Dec 15, 2014 1:20 pm

mick86 wrote:
KiDo_Tuning wrote:
mick86 wrote:still having engine light issue. spoke to MRT in Sydney and they say they cant tune the car. because the 2.0R model has a different computer to the other models. my only option now it seems, is to have Subaru in town, pull apart the engine and decarbonise. they think this is what is causing the issue. but im thinking it will be a waste of almost $3000. and by the looks of it, no one else has had this same issue. normally u replace the pump and your all sorted. but in my case pumps been replaced on 5 occasions and light fault code returns. annoying.


Doing one right now actually. The airpump issue is failing a cold start emissions test. Disable the codes, sorted since a 8+yr old car does not need an emissions test as long as it has a catalytic converter


I have been to a couple dyno tune places. Both have said cannot be done on this model car. So now I am getting a full pull apart and carbon clean out done by subaru.


I am buying a few ECU's to do exchange 2.0R tuning. Flash tune in, send to customer etc
KiDo Racing Tunes Info: HERE

Great minds discuss ideas;
Average minds discuss events;
Small minds discuss people
User avatar
KiDo_Tuning
 
Posts: 2798
Joined: Sun Jun 10, 2012 11:53 pm
Car: Subarus + Nissans
Real name: Matt

Re: GEN4 liberty Secondary air pump Issues...

Postby triston » Mon Dec 15, 2014 2:34 pm

I thought only the turbos had secondary air pumps. anyway mine went earlier this year. MSR disabled mine (didn't remove), I think it cost about $40-50. though I have a 2.5t so none of my experience may apply to you.
User avatar
triston
 
Posts: 100
Joined: Tue Apr 26, 2011 6:34 pm
Location: Sydney
Car: 08 GT-B tuned by Sti

Re: GEN4 liberty Secondary air pump Issues...

Postby gen4cruiser » Thu Dec 18, 2014 12:08 pm

KiDo_Tuning wrote:I am buying a few ECU's to do exchange 2.0R tuning. Flash tune in, send to customer etc


Will send you a PM, but how much is this option and do you think it can fix the way that some 2.0R's hesitate?
gen4cruiser
formerly aucix
 
Posts: 19
Joined: Tue Sep 03, 2013 4:05 pm

Re: GEN4 liberty Secondary air pump Issues...

Postby mick86 » Fri Dec 19, 2014 8:35 am

triston wrote:I thought only the turbos had secondary air pumps. anyway mine went earlier this year. MSR disabled mine (didn't remove), I think it cost about $40-50. though I have a 2.5t so none of my experience may apply to you.


Yeah na. I've already been to a few places trying to have the codes done. I've had the air pump and valves done 5 times. And currently my car is at subaru for some major work. They said maybe a week. Gotta pull apart everything to find what's triggering the issue. They think it's just carbonisation. Will be an expensive bill tho.
User avatar
mick86
 
Posts: 14
Joined: Mon Sep 01, 2014 9:41 pm
Car: 05 Gen4 Liberty
Real name: mick

Next

Return to 2.0R engine specific

Who is online

Users browsing this forum: No registered users and 1 guest