Member profile - quasarcreator's H6 Wagon

Show off what mods you've done to your car.

Member profile - quasarcreator's H6 Wagon

Postby quasarcreator » Wed Dec 06, 2017 8:46 pm

Finally decided to make a build list/thread.
Been a member of this forum since march 2016, but got my lib in June this year (2017) and have been loving every minute of it.

My car is a 2008 3.0r spec B wagon, with the 6-speed and in diamond grey :)
When I picked it up it had around 96,000 km on it.

In any case, here's some photos of the car currently, completely stock, aside from a few stickers :wink: I love taking photos so I expect this to be quite a photo heavy thread, just a heads up haha.

Image

Image

Image

Image

Image

Image

Image

Image
User avatar
quasarcreator
 
Posts: 15
Joined: Wed Mar 23, 2016 3:32 pm
Location: Sydney
Car: 2008 3.0r spec. B wagon 6mt
Real name: Luka

Re: Member profile - quasarcreator's H6 Wagon

Postby quasarcreator » Wed Dec 06, 2017 9:07 pm

Yesterday I went to the local car audio store (Ryda Dot Com) to get a replacement sub, as the stock Mcintosh one had given up on me - making annoying farting noises on kicks and loud bass. The guy recommended an 8 inch Kenwood sub, which would apparently fit with "a bit of bending of the metal with a hammer". Got home and noticed that it would require a lot more work than that.
In any case, I went back today to get a refund, which fortunately, they gave me. Asked one of the staff to have a look to see what I was talking about, and he then proceeded to tell me that they've never done an install on a wagon, only on sedans, which means it wouldn't fit. Would have been great to know that when I bought it (even though I specifically said I had a wagon) :angry2:

Image
The fairly beaten up stock grille, with the sub behind
Image
What was destined to be the replacement sub
Image
The cracking around the cone - it's possible to lift the entire cone off the rim
Image
A close up.

Drove around without the sub in, and honestly I couldn't even tell the difference. It sounds almost tighter without it, which is weird
Went to a different audio shop today, the guy working there said there are no aftermarket subs which fit the stock mounting position. Is this true? I find it hard to believe... he said it would be $350 to get the Mcintosh refurbished... which seems like a waste of money. A simple amp and sub would be between $300 -$400, however I don't really want to loose any boot space. Hmm. Need to do a bit of research into this.
User avatar
quasarcreator
 
Posts: 15
Joined: Wed Mar 23, 2016 3:32 pm
Location: Sydney
Car: 2008 3.0r spec. B wagon 6mt
Real name: Luka

Re: Member profile - quasarcreator's H6 Wagon

Postby quasarcreator » Wed Dec 06, 2017 9:22 pm

Today, I also investigated my not-working reverse lights. Initially I figured it could be that the bulbs had blown, but it seemed very strange that two of them would break at the same time - so decided against buying replacements. My other suspicion was that it could be a wiring issue - something that would be a big pain to work out.
After checking the bulbs themselves and noticing that the filaments were all still intact, I was ready to leave it for tomorrow until my dad suggested to check the fuses. After consulting the owner's manual, I located the reverse light fuse (number 18), got the fuse puller and spare 10 amp fuse from the engine bay fuse box, and replaced it. Sure enough, the reverse lights started working again! I wasn't excepting a blown fuse, so it was quite surprising haha :) Was hoping blown bulbs would give me an excuse to get fancy aftermarket ones, but alas... another day haha.

[iImage
The inside of the fuse box

Image

The very handy fuse pulling tool

Image

The blown fuse - note the broken connection inside the plastic housing, and the black marks on the pins

Image

The now functioning again reverse lights :D

This turned out to be a very easy fix, which is great because it definitely isn't safe to be driving around without reverse lights - had a few people beep at me when I stopped to reverse park, and fair enough, they probably had no idea what I was doing haha
User avatar
quasarcreator
 
Posts: 15
Joined: Wed Mar 23, 2016 3:32 pm
Location: Sydney
Car: 2008 3.0r spec. B wagon 6mt
Real name: Luka

Re: Member profile - quasarcreator's H6 Wagon

Postby applegeek897 » Thu Dec 07, 2017 6:57 pm

Car looks good man, top photos are broken. Keen to see them!
Daily: '00 Daihatsu Cuore "Kelly" - Build Thread -
Project / Weekender: '05 Subaru Liberty 3.0R-B Wagon - Build Thread -
Motorcycle: '14 Triumph Street Triple 660 - Build Thread -
User avatar
applegeek897
 
Posts: 177
Joined: Sun Jun 07, 2015 1:02 am
Location: Sydney, NSW
Car: 05' 3R-B Wagon, 00' Daihatsu Cuore
Real name: James
Profile URL: viewtopic.php?f=10&t=31247

Re: Member profile - quasarcreator's H6 Wagon

Postby dan_ashcroft » Thu Dec 07, 2017 9:14 pm

Lucky it was only fuses and not the reverse light switch!

(Can't help with any wagon audio info as I have a sedan.)
dan_ashcroft
 
Posts: 170
Joined: Tue May 19, 2015 8:12 am
Location: Sydney
Car: MY06 3.0R-B on E85

Re: Member profile - quasarcreator's H6 Wagon

Postby MadmanSean » Mon Dec 11, 2017 7:21 am

Yay another Wagon!
Keen to see the pics of your car, fix the pics asap :)
Garage:
2007 Subaru Liberty GT SpecB wagon - RIP
Cosmic Racing Coilovers | Kobe 340 Pump | AVO 3" Inlet | ID1000 | DBA T2 Discs | MU NS400 Pads | Invidia DP | Tomei FPR | Tuspeed BCS | GTX3071 | TGV Delete | W2A Intercooled | Catch Can | 20 Row Trans Cooler | Cusco Stuff | Whiteline Stuffs | Kido Tuned E85 | Empire 3" Exhaust |

1996 Hilux Surf SSRG
Non intercooled 1kz-te | Diesel | Auto | 2" Lift | 12psi MBCS | K&N Filter | 33" Muddies | 80.6RWkW
User avatar
MadmanSean
 
Posts: 157
Joined: Tue Mar 17, 2015 6:27 pm
Location: Melbourne
Car: 2007 Libert GT SpecB wagon
Real name: Sean
Profile URL: viewtopic.php?f=10&t=33793


Return to Post your mods

Who is online

Users browsing this forum: No registered users and 3 guests